aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/bacula-web/Makefile15
-rw-r--r--www/fluxbb/Makefile15
-rw-r--r--www/groupoffice/Makefile27
-rw-r--r--www/mod_clamav/Makefile11
-rw-r--r--www/nibbleblog/Makefile14
-rw-r--r--www/py-django-photologue/Makefile13
-rw-r--r--www/snownews/Makefile17
-rw-r--r--www/trac-revtree/Makefile18
-rw-r--r--www/vtiger/Makefile16
9 files changed, 62 insertions, 84 deletions
diff --git a/www/bacula-web/Makefile b/www/bacula-web/Makefile
index 0c5c31c4bdc1..ca9dfdf9b412 100644
--- a/www/bacula-web/Makefile
+++ b/www/bacula-web/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bacula-web
-# Date created: 28 April 2006
-# Whom: Dan Langille <dan@langille.org>
-#
+# Created by: Dan Langille <dan@langille.org>
# $FreeBSD$
-#
PORTNAME= bacula-web
DISTVERSION= 1.38.9
@@ -21,13 +17,14 @@ NO_BUILD= yes
USE_PHP= gd
WANT_PHP_WEB= yes
-OPTIONS= POSTGRESQL "Use PostgreSQL database instead of MySQL" on
+OPTIONS_DEFINE= PGSQL
+OPTIONS_DEFAULT= PGSQL
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql=yes
SUB_LIST+= REQ_PGSQL=postgresql
@@ -57,4 +54,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/fluxbb/Makefile b/www/fluxbb/Makefile
index 780da7d602f5..ad0d66a4c7d1 100644
--- a/www/fluxbb/Makefile
+++ b/www/fluxbb/Makefile
@@ -17,21 +17,18 @@ SUB_FILES= pkg-message
NO_BUILD= yes
USE_PHP= yes
-OPTIONS= MYSQL "Add support for a MySQL database server" On \
- PGSQL "Add support for a PostgreSQL database server" Off \
- SQLITE "Add support for a SQLite database server" Off
+OPTIONS_DEFINE= MYSQL PGSQL SQLITE
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_PHP+= sqlite
.endif
@@ -47,4 +44,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/groupoffice/Makefile b/www/groupoffice/Makefile
index 9cbc6e2b68c6..69b430f62851 100644
--- a/www/groupoffice/Makefile
+++ b/www/groupoffice/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: www/groupoffice
-# Date created: 16 February 2007
-# Whom: Aron Schlesinger <as@bsdgroup.de>
-#
+# Created by: Aron Schlesinger <as@bsdgroup.de>
# $FreeBSD$
PORTNAME= groupoffice
@@ -23,26 +20,28 @@ WWWDIR?= ${PREFIX}/www/${PORTNAME}3
SUB_FILES= pkg-message
-OPTIONS= IMAP "IMAP support" on \
- GD "Gallery support (GD)" on \
- CALENDAR "Calendar holiday support" on \
- WBXML "Synchronization support" off
+OPTIONS_DEFINE= IMAP GD CALENDAR WBXML
+OPTIONS_DEFAULT= IMAP GD CALENDAR
+CALENDAR_DESC= Calendar holiday support
+IMAP_DESC= IMAP support
+GD_DESC= Gallery support (GD)
+WBXML_DESC= Synchronization Support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_IMAP)
+.if ${PORT_OPTIONS:MIMAP}
USE_PHP+= imap iconv
.endif
-.if !defined(WITHOUT_GD)
+.if ${PORT_OPTIONS:MGD}
USE_PHP+= gd
.endif
-.if !defined(WITHOUT_CALENDAR)
+.if ${PORT_OPTIONS:MCALENDAR}
USE_PHP+= calendar
.endif
-.if !defined(WITHOUT_WBXML)
+.if ${PORT_OPTIONS:MWBXML}
LIB_DEPENDS= wbxml2:${PORTSDIR}/textproc/wbxml2
.endif
@@ -61,4 +60,4 @@ create-plist:
@${FIND} -ds ${WRKSRC}/${file} -type d \
| ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index b6fc82d1ad86..da4dee889e0e 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mod_clamav
-# Date created: Sun Oct 19
-# Whom: Clement Laforet <clement@FreeBSD.org>
-#
+# Created by: Clement Laforet <clement@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mod_clamav
PORTVERSION= 0.23
@@ -22,11 +18,12 @@ USE_AUTOTOOLS= libtool
USE_APACHE= 22
GNU_CONFIGURE= yes
-OPTIONS= CLAMAVDEVEL "Use development version of CLAMAV" off
+OPTIONS_DEFINE= CLAMAVDEVEL
+CLAMAVDEVEL_DESC= development version of CLAMAV
.include <bsd.port.options.mk>
-.if defined(WITH_CLAMAVDEVEL)
+.if ${PORT_OPTIONS:MCLAMAVDEVEL}
LIB_DEPENDS+= clamav.7:${PORTSDIR}/security/clamav-devel
.else
CLAMAV_PORT= security/clamav
diff --git a/www/nibbleblog/Makefile b/www/nibbleblog/Makefile
index 90dc34e42ad1..a520fd7b374b 100644
--- a/www/nibbleblog/Makefile
+++ b/www/nibbleblog/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nibbleblog
-# Date created: 15 January 2011
-# Whom: Marek Holienka <marekholienka@gmail.com>
-#
+# Created by: Marek Holienka <marekholienka@gmail.com>
# $FreeBSD$
-#
PORTNAME= nibbleblog
PORTVERSION= 3.0.2
@@ -17,8 +13,8 @@ COMMENT= A lightweight blog system for general use
RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
-OPTIONS= APACHE "Enable Apache Support" on \
- LIGHTTPD "Enable Lighttpd Support" off
+OPTIONS_DEFINE= APACHE LIGHTTPD
+OPTIONS_DEFAULT= APACHE
USE_ZIP= yes
NO_BUILD= yes
@@ -28,10 +24,10 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
.endif
-.if defined(WITH_LIGHTTPD)
+.if ${PORT_OPTIONS:MLIGHTTPD}
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
diff --git a/www/py-django-photologue/Makefile b/www/py-django-photologue/Makefile
index 98b596a88be3..65c92aae29e0 100644
--- a/www/py-django-photologue/Makefile
+++ b/www/py-django-photologue/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-django-photologue
-# Date created: 12 January 2012
-# Whom: Kevin Golding <ports@caomhin.org>
-#
+# Created by: Kevin Golding <ports@caomhin.org>
# $FreeBSD$
-#
PORTNAME= django-photologue
PORTVERSION= 2.2
@@ -25,16 +21,17 @@ USE_ZIP= yes
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-OPTIONS= TAGGING "Enable tagging" On
+OPTIONS_DEFINE= TAGGING DOCS
+OPTIONS_DEFAULT= TAGGING
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_TAGGING)
+.if ${PORT_OPTIONS:MTAGGING}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/tagging/models.py:${PORTSDIR}/www/py-django-tagging
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index 0418318c153a..c14463acb802 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: snownews
-# Date created: Nov 3 2003
-# Whom: Cheng-Lung Sung <clsung@dragon2.net>
-#
+# Created by: Cheng-Lung Sung <clsung@dragon2.net>
# $FreeBSD$
-#
PORTNAME= snownews
PORTVERSION= 1.5.12
@@ -20,16 +15,18 @@ USE_GMAKE= yes
USE_GNOME= libxml2
HAS_CONFIGURE= yes
-OPTIONS= OPML "Outline Processor Markup Support" on
+OPTIONS_DEFINE= OPML NLS
+OPTIONS_DEFAULT= OPML
+OPML_DESC= Outline Processor Markup Support
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_OPML)
+.if ! ${PORT_OPTIONS:MOPML}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile
PLIST_SUB+= OPML="@comment "
.else
@@ -48,7 +45,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|make|${GMAKE}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/Makefile
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e 's/ install-locales / /g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's/ locales$$//g' ${WRKSRC}/Makefile
.endif
diff --git a/www/trac-revtree/Makefile b/www/trac-revtree/Makefile
index df09e34b93c8..c56c281f8f49 100644
--- a/www/trac-revtree/Makefile
+++ b/www/trac-revtree/Makefile
@@ -19,8 +19,10 @@ COMMENT= Graphical representation of an SVN repository
RUN_DEPENDS+= trac>=0.12:${PORTSDIR}/www/trac \
subversion>=0:${PORTSDIR}/devel/subversion
-OPTIONS= MINFOENH "Enable mergeinfo display enhancer" On \
- LOGENH "Enable log message display enhancer" Off
+OPTIONS_DEFINE= MINFOENH LOGENH
+OPTIONS_DEFAULT= MINFOENH
+MINFOENH_DESC= Enable mergeinfo display enhancer
+LOGENH_DESC= Enable log message display enhancer
USE_ZIP= yes
@@ -32,9 +34,9 @@ PYDISTUTILS_PKGVERSION= ${PORTVERSION}dev
PLIST_SUB+= EGGVERSION="${PORTVERSION}dev" PYTHONVERSION=${_PYTHON_VERSION}
PYDISTUTILS_NOEGGINFO= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MINFOENH)
+.if ${PORT_OPTIONS:MMINFOENH}
MINFOENH_VERSION= 0.2.1
PLIST_SUB+= MINFOENH_EGGVERSION="${MINFOENH_VERSION}dev"
ENH1=""
@@ -43,7 +45,7 @@ ENH1="@comment "
.endif
PLIST_SUB+= ENH1=${ENH1}
-.if defined(WITH_LOGENH)
+.if ${PORT_OPTIONS:MLOGENH}
LOGENH_VERSION= 0.2.0
PLIST_SUB+= LOGENH_EGGVERSION="${LOGENH_VERSION}dev"
ENH2=""
@@ -54,14 +56,14 @@ PLIST_SUB+= ENH2=${ENH2}
post-install:
# Install the selected enhancer plugins
-.if defined(WITH_MINFOENH)
+.if ${PORT_OPTIONS:MMINFOENH}
@( cd ${WRKSRC}/enhancers/mergeinfoenhancer ; \
${PYEASYINSTALL_CMD} . )
.endif
-.if defined(WITH_LOGENH)
+.if ${PORT_OPTIONS:MLOGENH}
@( cd ${WRKSRC}/enhancers/logenhancer ; \
${PYEASYINSTALL_CMD} . )
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/vtiger/Makefile b/www/vtiger/Makefile
index 8dc422567d65..ef1d56e6ebe5 100644
--- a/www/vtiger/Makefile
+++ b/www/vtiger/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vtiger
-# Date created: Fri Mar 11 20:59:31 EST 2005
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-#
+# Created by: Edwin Groothuis <edwin@mavetju.org>
# $FreeBSD$
-#
PORTNAME= vtiger
PORTVERSION= 5.0.3
@@ -24,17 +20,17 @@ IGNORE_WITH_PHP= 4
WRKSRC= ${WRKDIR}/vtigercrm
-OPTIONS= MYSQLSERVER "Use MySQL-Server on localhost" OFF
+OPTIONS_DEFINE= MYSQL
.include <bsd.port.pre.mk>
CONFLICTS= vtiger-4.*
-.if !defined(WITHOUT_MYSQLSERVER)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= Release_Notes.html DEPENDENCIES.txt README.txt
.endif
@@ -78,7 +74,7 @@ post-install:
@${CHMOD} u+w ${WWWDIR}/${FILE}
. endif
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for FILE in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -115,4 +111,4 @@ create-plist:
@${FIND} -ds ${WRKSRC} -type d \
| ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>