aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mod_spdy/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 9af4d3098209..6ca0f87a8cec 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -46,15 +46,26 @@ SUB_LIST+= APACHEMODDIR=${APACHEMODDIR}
OPTIONS_DEFINE= GCC DEBUG
+# workaround for archs with no clang in base, part 1:
+# do not include the option to turn GCC off. Instead, force its use.
+OPTIONS_EXCLUDE_sparc64= GCC
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGCC}
+# workaround for archs with no clang in base, part 2
+.if ${PORT_OPTIONS:MGCC} || ${ARCH} == sparc64
+FORCE_GCC= yes
+.else
+FORCE_GCC= no
+.endif
+
+.if ${FORCE_GCC} == yes
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif
-.if ${PORT_OPTIONS:MGCC}
+.if ${FORCE_GCC} == yes
USE_GCC?= yes
GYP_DEFINES+= gcc_version=${CXX:S/g++//}
.else
@@ -103,7 +114,7 @@ post-patch:
-e 's,%%FILESDIR%%,${FILESDIR},g' \
-e 's,%%OPENSSLBASE%%,${OPENSSLBASE},g' \
${WRKSRC}/build_modssl_with_npn.sh
-.if ${PORT_OPTIONS:MGCC}
+.if ${FORCE_GCC} == yes
@${REINPLACE_CMD} -e 's,%%GCCCXXFLAGS%%,-I${LOCALBASE}/lib/gcc${CXX:S/g++//}/include,g' \
-e 's,%%GCCLDFLAGS%%,-L${LOCALBASE}/lib/gcc${CXX:S/g++//},g' \
${WRKSRC}/Makefile