aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mochiweb/Makefile26
-rw-r--r--www/mochiweb/distinfo4
-rw-r--r--www/mochiweb/pkg-plist2
3 files changed, 19 insertions, 13 deletions
diff --git a/www/mochiweb/Makefile b/www/mochiweb/Makefile
index bf3695f0698b..75c05f0934d7 100644
--- a/www/mochiweb/Makefile
+++ b/www/mochiweb/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mochiweb
-PORTVERSION= 2.10.0
+PORTVERSION= 2.12.2
DISTVERSIONPREFIX= v
CATEGORIES= www devel
@@ -10,8 +10,8 @@ COMMENT= Erlang library for building lightweight HTTP servers
LICENSE= MIT
-BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
-RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+BUILD_DEPENDS= erl:${PORTSDIR}/lang/erlang
+RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= mochiweb-basho-[0-9]*
@@ -20,21 +20,25 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USE_GITHUB= yes
GH_ACCOUNT= mochi
-PORTDOCS= *
+.include <bsd.port.options.mk>
do-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
for FILE in CHANGES.md README; do \
${INSTALL_DATA} ${WRKSRC}/$${FILE} ${STAGEDIR}${DOCSDIR}; \
done
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/ebin
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/include
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/src
- ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/ebin
- ${INSTALL_DATA} ${WRKSRC}/include/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/include
- ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/mochiweb-${PORTVERSION}/src
+.endif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+ ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/include
+ ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
.include <bsd.port.mk>
diff --git a/www/mochiweb/distinfo b/www/mochiweb/distinfo
index 1ed2ae3d935b..7213a33822e9 100644
--- a/www/mochiweb/distinfo
+++ b/www/mochiweb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mochi-mochiweb-v2.10.0_GH0.tar.gz) = e830a767a8e4b575d9da46ffc8bdfe1b5f4493353082280c4a1a692588499307
-SIZE (mochi-mochiweb-v2.10.0_GH0.tar.gz) = 278224
+SHA256 (mochi-mochiweb-v2.12.2_GH0.tar.gz) = 73369f5a2e0d5477632a3d1fa44c674f2dfc98908f86bfd6bd77b266bdb88684
+SIZE (mochi-mochiweb-v2.12.2_GH0.tar.gz) = 284186
diff --git a/www/mochiweb/pkg-plist b/www/mochiweb/pkg-plist
index 5f741c7037b1..19dc5154a621 100644
--- a/www/mochiweb/pkg-plist
+++ b/www/mochiweb/pkg-plist
@@ -67,6 +67,8 @@ lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_socket_server.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_util.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/mochiweb_websocket.erl
lib/erlang/lib/mochiweb-%%VERSION%%/src/reloader.erl
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.md
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api.hrl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hmac_api/hmac_api_client.erl