aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mod_uid/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/www/mod_uid/Makefile b/www/mod_uid/Makefile
index dfb74d224cbd..d2ff992365f5 100644
--- a/www/mod_uid/Makefile
+++ b/www/mod_uid/Makefile
@@ -19,15 +19,18 @@ USE_APACHE= 1.3+
PORTDOCS= README.html
-.if !defined(APACHE_PORT) || ${APACHE_PORT} == "www/apache13"
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(APACHE_PORT) || ${APACHE_PORT} == "www/apache13" || ${APACHE_VERSION} == "13"
MODULENAME= mod_uid
.else
+IGNORE= does not build with latest apache20/22
MODULENAME= mod_uid2
.endif
-AP_FAST_BUILD= yes
-AP_GENPLIST= yes
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -36,4 +39,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>