aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/kdewebdev/Makefile3
-rw-r--r--www/kdewebdev4/Makefile3
-rw-r--r--www/quanta/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/www/kdewebdev/Makefile b/www/kdewebdev/Makefile
index a1f9ef6cbb47..1fe4c3dc71ad 100644
--- a/www/kdewebdev/Makefile
+++ b/www/kdewebdev/Makefile
@@ -31,6 +31,9 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index a1f9ef6cbb47..1fe4c3dc71ad 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -31,6 +31,9 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/quanta/Makefile b/www/quanta/Makefile
index a1f9ef6cbb47..1fe4c3dc71ad 100644
--- a/www/quanta/Makefile
+++ b/www/quanta/Makefile
@@ -31,6 +31,9 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
DOCS= css html javascript php