aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/xpi-forecastfox/Makefile25
-rw-r--r--www/xpi-forecastfox/distinfo3
-rw-r--r--www/xpi-forecastfox/files/chrome.manifest48
-rw-r--r--www/xpi-forecastfox/pkg-descr8
-rw-r--r--www/xpi-forecastfox/pkg-plist50
6 files changed, 135 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a94fdb1d2d19..43d62a9736ec 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -993,6 +993,7 @@
SUBDIR += xpi-fission
SUBDIR += xpi-flashblock
SUBDIR += xpi-flashgot
+ SUBDIR += xpi-forecastfox
SUBDIR += xpi-gbrain
SUBDIR += xpi-google-notebook
SUBDIR += xpi-greasemonkey
diff --git a/www/xpi-forecastfox/Makefile b/www/xpi-forecastfox/Makefile
new file mode 100644
index 000000000000..a344975cd68e
--- /dev/null
+++ b/www/xpi-forecastfox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: forecastfox
+# Date created: 2006-05-15
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= forecastfox
+PORTVERSION= 0.9.0.2
+DISTVERSIONSUFFIX= -fx+fl+mz+ns+zm
+CATEGORIES= www
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Get international weather forecasts and display it
+
+XPI_ID= {0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|install = this._app.clone();|install = app.clone();|g' \
+ ${WRKSRC}/components/ffDisk.js
+ @${RM} -f ${WRKSRC}/components/ffDisk.js.bak
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-forecastfox/distinfo b/www/xpi-forecastfox/distinfo
new file mode 100644
index 000000000000..f3177d034883
--- /dev/null
+++ b/www/xpi-forecastfox/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/forecastfox-0.9.0.2-fx+fl+mz+ns+zm.xpi) = ca70bac1f3fe5ca0d58c5fb91f006c86
+SHA256 (xpi/forecastfox-0.9.0.2-fx+fl+mz+ns+zm.xpi) = 5a64493ae4ec59d04ec08d498741d94edf7d759fd143a6386c1baab09c451882
+SIZE (xpi/forecastfox-0.9.0.2-fx+fl+mz+ns+zm.xpi) = 409011
diff --git a/www/xpi-forecastfox/files/chrome.manifest b/www/xpi-forecastfox/files/chrome.manifest
new file mode 100644
index 000000000000..357b421834db
--- /dev/null
+++ b/www/xpi-forecastfox/files/chrome.manifest
@@ -0,0 +1,48 @@
+
+overlay chrome://browser/content/browser.xul chrome://forecastfox/content/forecastfox.xul
+overlay chrome://navigator/content/navigator.xul chrome://forecastfox/content/forecastfox.xul
+content forecastfox jar:chrome/forecastfox.jar!/content/forecastfox/
+
+skin forecastfox classic/1.0 jar:chrome/forecastfox.jar!/skin/classic/forecastfox/
+
+locale forecastfox en-US jar:chrome/forecastfox.jar!/locale/en-US/forecastfox/
+
+locale forecastfox ca-AD jar:chrome/forecastfox.jar!/locale/ca-AD/forecastfox/
+
+locale forecastfox da-DK jar:chrome/forecastfox.jar!/locale/da-DK/forecastfox/
+
+locale forecastfox de-DE jar:chrome/forecastfox.jar!/locale/de-DE/forecastfox/
+
+locale forecastfox el-GR jar:chrome/forecastfox.jar!/locale/el-GR/forecastfox/
+
+locale forecastfox es-ES jar:chrome/forecastfox.jar!/locale/es-ES/forecastfox/
+
+locale forecastfox fr-FR jar:chrome/forecastfox.jar!/locale/fr-FR/forecastfox/
+
+locale forecastfox hu-HU jar:chrome/forecastfox.jar!/locale/hu-HU/forecastfox/
+
+locale forecastfox it-IT jar:chrome/forecastfox.jar!/locale/it-IT/forecastfox/
+
+locale forecastfox ja-JP jar:chrome/forecastfox.jar!/locale/ja-JP/forecastfox/
+
+locale forecastfox mn-MN jar:chrome/forecastfox.jar!/locale/mn-MN/forecastfox/
+
+locale forecastfox nb-NO jar:chrome/forecastfox.jar!/locale/nb-NO/forecastfox/
+
+locale forecastfox nl-NL jar:chrome/forecastfox.jar!/locale/nl-NL/forecastfox/
+
+locale forecastfox pl-PL jar:chrome/forecastfox.jar!/locale/pl-PL/forecastfox/
+
+locale forecastfox pt-BR jar:chrome/forecastfox.jar!/locale/pt-BR/forecastfox/
+
+locale forecastfox ru-RU jar:chrome/forecastfox.jar!/locale/ru-RU/forecastfox/
+
+locale forecastfox sk-SK jar:chrome/forecastfox.jar!/locale/sk-SK/forecastfox/
+
+locale forecastfox sl-SI jar:chrome/forecastfox.jar!/locale/sl-SI/forecastfox/
+
+locale forecastfox sv-SE jar:chrome/forecastfox.jar!/locale/sv-SE/forecastfox/
+
+locale forecastfox zh-TW jar:chrome/forecastfox.jar!/locale/zh-TW/forecastfox/
+
+locale forecastfox zh-CN jar:chrome/forecastfox.jar!/locale/zh-CN/forecastfox/
diff --git a/www/xpi-forecastfox/pkg-descr b/www/xpi-forecastfox/pkg-descr
new file mode 100644
index 000000000000..9f72a3f24d12
--- /dev/null
+++ b/www/xpi-forecastfox/pkg-descr
@@ -0,0 +1,8 @@
+Forecastfox is an extension that brings international weather from
+AccuWeather.com to your Firefox web browser. You can use your US zip code or
+you can easily find your town or city by using the built in search tool. It is
+unobtrusive and lightweight, yet can be customized to display nearly as much
+data as the leading desktop weather programs!
+
+Author: Jon Stritar <jstritar@mit.edu>
+WWW: http://forecastfox.mozdev.org/
diff --git a/www/xpi-forecastfox/pkg-plist b/www/xpi-forecastfox/pkg-plist
new file mode 100644
index 000000000000..9f74f8667804
--- /dev/null
+++ b/www/xpi-forecastfox/pkg-plist
@@ -0,0 +1,50 @@
+%%XPI_XPIDIR%%/chrome/forecastfox.jar
+%%XPI_XPIDIR%%/components/ffDisk.js
+%%XPI_XPIDIR%%/components/ffDisk.xpt
+%%XPI_XPIDIR%%/components/ffError.js
+%%XPI_XPIDIR%%/components/ffError.xpt
+%%XPI_XPIDIR%%/components/ffIconManager.js
+%%XPI_XPIDIR%%/components/ffIconManager.xpt
+%%XPI_XPIDIR%%/components/ffIconPack.js
+%%XPI_XPIDIR%%/components/ffIconPack.xpt
+%%XPI_XPIDIR%%/components/ffParser.js
+%%XPI_XPIDIR%%/components/ffParser.xpt
+%%XPI_XPIDIR%%/components/ffPing.js
+%%XPI_XPIDIR%%/components/ffPing.xpt
+%%XPI_XPIDIR%%/components/ffProfiles.js
+%%XPI_XPIDIR%%/components/ffProfiles.xpt
+%%XPI_XPIDIR%%/components/ffResolver.js
+%%XPI_XPIDIR%%/components/ffWeb.js
+%%XPI_XPIDIR%%/components/ffWeb.xpt
+%%XPI_XPIDIR%%/components/nsForecastfox.js
+%%XPI_XPIDIR%%/components/nsForecastfox.xpt
+%%XPI_XPIDIR%%/defaults/.autoreg
+%%XPI_XPIDIR%%/defaults/icons/default.jar
+%%XPI_XPIDIR%%/defaults/parser.xml
+%%XPI_XPIDIR%%/defaults/preferences/forecastfox.js
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.4.8.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.4.9.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.5.1.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.5.8.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.5.9.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.5.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.1.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.5.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.6.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.7.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.8.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.9.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.7.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.8.1.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.8.2.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.8.5.xsl
+%%XPI_XPIDIR%%/defaults/transforms/profiles-0.8.xsl
+%%XPI_XPIDIR%%/install.js
+%%XPI_XPIDIR%%/install.rdf
+%%XPI_XPIDIR%%/chrome.manifest
+@dirrm %%XPI_XPIDIR%%/chrome
+@dirrm %%XPI_XPIDIR%%/components
+@dirrm %%XPI_XPIDIR%%/defaults/icons
+@dirrm %%XPI_XPIDIR%%/defaults/preferences
+@dirrm %%XPI_XPIDIR%%/defaults/transforms
+@dirrm %%XPI_XPIDIR%%/defaults