aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/p5-CatalystX-Profile/Makefile6
-rw-r--r--www/p5-Gungho/Makefile18
-rw-r--r--www/p5-Jifty/Makefile8
-rw-r--r--www/p5-Kwiki/Makefile2
-rw-r--r--www/p5-MasonX-Profiler/Makefile5
-rw-r--r--www/p5-Mojolicious-Plugin-Authentication/Makefile2
-rw-r--r--www/p5-Net-Amazon-AWIS/Makefile9
-rw-r--r--www/p5-POE-Component-Client-HTTP/Makefile5
-rw-r--r--www/p5-Rose-HTML-Objects/Makefile9
-rw-r--r--www/p5-URI-Fetch/Makefile11
-rw-r--r--www/p5-WWW-Facebook-API/Makefile5
-rw-r--r--www/p5-WWW-Mechanize-Shell/Makefile7
-rw-r--r--www/p5-WWW-NioTV/Makefile5
-rw-r--r--www/p5-WebService-YouTube/Makefile5
14 files changed, 37 insertions, 60 deletions
diff --git a/www/p5-CatalystX-Profile/Makefile b/www/p5-CatalystX-Profile/Makefile
index c92e5e25304f..8ab815e911e8 100644
--- a/www/p5-CatalystX-Profile/Makefile
+++ b/www/p5-CatalystX-Profile/Makefile
@@ -20,11 +20,7 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.80020:${PORTSDIR}/www/p5-Catalyst-Runtime
devel/p5-Devel-NYTProf>=3.01:${PORTSDIR}/devel/p5-Devel-NYTProf \
p5-Moose>=0.93:${PORTSDIR}/devel/p5-Moose \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
-RUN_DEPENDS= p5-Catalyst-Runtime>=5.80020:${PORTSDIR}/www/p5-Catalyst-Runtime \
- p5-CatalystX-InjectComponent>=0.024:${PORTSDIR}/www/p5-CatalystX-InjectComponent \
- devel/p5-Devel-NYTProf>=3.01:${PORTSDIR}/devel/p5-Devel-NYTProf \
- p5-Moose>=0.93:${PORTSDIR}/devel/p5-Moose \
- p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-Gungho/Makefile b/www/p5-Gungho/Makefile
index e0e67e22c6b9..04c4f8ee34ef 100644
--- a/www/p5-Gungho/Makefile
+++ b/www/p5-Gungho/Makefile
@@ -16,34 +16,34 @@ COMMENT= Event Based High Performance Web Crawler Framework
BUILD_DEPENDS= p5-Best>=0:${PORTSDIR}/devel/p5-Best \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-C3-Componentised>=0:${PORTSDIR}/devel/p5-Class-C3-Componentised \
+ p5-Class-C3-XS>=0.02:${PORTSDIR}/devel/p5-Class-C3-XS \
+ p5-Class-C3>=0.16:${PORTSDIR}/devel/p5-Class-C3 \
p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
p5-Danga-Socket-Callback>=0:${PORTSDIR}/devel/p5-Danga-Socket-Callback \
+ p5-Danga-Socket>=1.57:${PORTSDIR}/devel/p5-Danga-Socket \
+ p5-Data-Throttler-Memcached>=0.0003:${PORTSDIR}/devel/p5-Data-Throttler-Memcached \
p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler \
+ p5-Event-Notify>=0.00004:${PORTSDIR}/devel/p5-Event-Notify \
p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
p5-HTML-RobotsMETA>=0:${PORTSDIR}/www/p5-HTML-RobotsMETA \
p5-HTTP-Parser>=0:${PORTSDIR}/www/p5-HTTP-Parser \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-IO-Async>=0:${PORTSDIR}/devel/p5-IO-Async \
p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
p5-POE-Component-Client-DNS>=0:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
+ p5-POE-Component-Client-HTTP>=0.81:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
p5-POE-Component-Client-Keepalive>=0:${PORTSDIR}/net/p5-POE-Component-Client-Keepalive \
+ p5-POE>=0.9999:${PORTSDIR}/devel/p5-POE \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-UNIVERSAL-isa>=0.06:${PORTSDIR}/devel/p5-UNIVERSAL-isa \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-WWW-RobotRules-Parser>=0:${PORTSDIR}/www/p5-WWW-RobotRules-Parser \
p5-Web-Scraper-Config>=0:${PORTSDIR}/www/p5-Web-Scraper-Config \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
- p5-Class-C3-XS>=0.02:${PORTSDIR}/devel/p5-Class-C3-XS \
- p5-Class-C3>=0.16:${PORTSDIR}/devel/p5-Class-C3 \
- p5-Danga-Socket>=1.57:${PORTSDIR}/devel/p5-Danga-Socket \
- p5-Data-Throttler-Memcached>=0.0003:${PORTSDIR}/devel/p5-Data-Throttler-Memcached \
- p5-Event-Notify>=0.00004:${PORTSDIR}/devel/p5-Event-Notify \
- p5-POE-Component-Client-HTTP>=0.81:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
- p5-POE>=0.9999:${PORTSDIR}/devel/p5-POE \
- p5-UNIVERSAL-isa>=0.06:${PORTSDIR}/devel/p5-UNIVERSAL-isa
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5 shebangfix
diff --git a/www/p5-Jifty/Makefile b/www/p5-Jifty/Makefile
index dc93fd5280b4..8595b87044c2 100644
--- a/www/p5-Jifty/Makefile
+++ b/www/p5-Jifty/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Jifty
PORTVERSION= 1.10518
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SARTAK
@@ -12,7 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Jifty -- Just Do It -- Yet another web framework
-BUILD_DEPENDS= p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
+BUILD_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
p5-CGI-Cookie-Splitter>=0:${PORTSDIR}/www/p5-CGI-Cookie-Splitter \
p5-CGI-Emulate-PSGI>=0.06:${PORTSDIR}/www/p5-CGI-Emulate-PSGI \
p5-CSS-Squish>=0.05:${PORTSDIR}/textproc/p5-CSS-Squish \
@@ -86,8 +87,7 @@ BUILD_DEPENDS= p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
p5-XML-XPath>0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML \
p5-YAML-Syck>=0.71:${PORTSDIR}/textproc/p5-YAML-Syck \
- p5-libwww>0:${PORTSDIR}/www/p5-libwww \
- p5-version>0:${PORTSDIR}/devel/p5-version
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Base>=0.44:${PORTSDIR}/devel/p5-Test-Base \
p5-Test-HTTP-Server-Simple>=0.02:${PORTSDIR}/www/p5-Test-HTTP-Server-Simple \
diff --git a/www/p5-Kwiki/Makefile b/www/p5-Kwiki/Makefile
index fbd40c7227cf..04602cb2b7b9 100644
--- a/www/p5-Kwiki/Makefile
+++ b/www/p5-Kwiki/Makefile
@@ -22,6 +22,6 @@ PLIST_SUB= KWIKIDIR=${KWIKIDIR}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${KWIKIDIR}
- cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${KWIKIDIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${KWIKIDIR})
.include <bsd.port.mk>
diff --git a/www/p5-MasonX-Profiler/Makefile b/www/p5-MasonX-Profiler/Makefile
index 32be7c730df8..04b4cdb9a971 100644
--- a/www/p5-MasonX-Profiler/Makefile
+++ b/www/p5-MasonX-Profiler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= MasonX-Profiler
PORTVERSION= 0.06
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,8 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Mason per-component profiler
-BUILD_DEPENDS= p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/www/p5-Mojolicious-Plugin-Authentication/Makefile b/www/p5-Mojolicious-Plugin-Authentication/Makefile
index 80f61e7983f4..8609bd3096cb 100644
--- a/www/p5-Mojolicious-Plugin-Authentication/Makefile
+++ b/www/p5-Mojolicious-Plugin-Authentication/Makefile
@@ -17,7 +17,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Mojolicious>=0:${PORTSDIR}/www/p5-Mojolicious
RUN_DEPENDS= p5-Mojolicious>=0:${PORTSDIR}/www/p5-Mojolicious
-USES= perl5
+USES= perl5
USE_PERL5= configure
post-patch:
diff --git a/www/p5-Net-Amazon-AWIS/Makefile b/www/p5-Net-Amazon-AWIS/Makefile
index 5bec739dc798..a84eca45a14a 100644
--- a/www/p5-Net-Amazon-AWIS/Makefile
+++ b/www/p5-Net-Amazon-AWIS/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Net-Amazon-AWIS
PORTVERSION= 0.36
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +14,15 @@ COMMENT= Use the Amazon Alexa Web Information Service
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-POE-Component-Client-HTTP/Makefile b/www/p5-POE-Component-Client-HTTP/Makefile
index 03bc7719ec0a..89440250302a 100644
--- a/www/p5-POE-Component-Client-HTTP/Makefile
+++ b/www/p5-POE-Component-Client-HTTP/Makefile
@@ -3,7 +3,7 @@
PORTNAME= POE-Component-Client-HTTP
PORTVERSION= 0.9480
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:RCAPUTO
@@ -19,8 +19,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-POE>=1.312:${PORTSDIR}/devel/p5-POE \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=1.37:${PORTSDIR}/net/p5-URI \
- p5-POE-Component-Client-Keepalive>=0.2710:${PORTSDIR}/net/p5-POE-Component-Client-Keepalive \
- p5-Socket>=2.001:${PORTSDIR}/net/p5-Socket
+ p5-POE-Component-Client-Keepalive>=0.2710:${PORTSDIR}/net/p5-POE-Component-Client-Keepalive
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-POE-Server-TCP>=1.14:${PORTSDIR}/devel/p5-Test-POE-Server-TCP
diff --git a/www/p5-Rose-HTML-Objects/Makefile b/www/p5-Rose-HTML-Objects/Makefile
index a2edd26a32d6..aca96a5c8821 100644
--- a/www/p5-Rose-HTML-Objects/Makefile
+++ b/www/p5-Rose-HTML-Objects/Makefile
@@ -33,11 +33,4 @@ PORTSCOUT= skipv:0.6061
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501600
-BUILD_DEPENDS+= p5-base>=2.18:${PORTSDIR}/devel/p5-base
-RUN_DEPENDS+= p5-base>=2.18:${PORTSDIR}/devel/p5-base
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 1a78a80d62c8..4a1f4c8e02c0 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -17,19 +17,14 @@ BUILD_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= ZLIB CACHE
-OPTIONS_DEFAULT= ZLIB
+OPTIONS_DEFINE= CACHE
-ZLIB_DESC= GZIP Support
CACHE_DESC= Caching Support
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MCACHE}
-RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
-.endif
+CACHE_BUILD_DEPENDS= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
+CACHE_RUN_DEPENDS= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Facebook-API/Makefile b/www/p5-WWW-Facebook-API/Makefile
index 0d17a137cfa7..4851057d076b 100644
--- a/www/p5-WWW-Facebook-API/Makefile
+++ b/www/p5-WWW-Facebook-API/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WWW-Facebook-API
PORTVERSION= 0.4.18
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +14,11 @@ COMMENT= Facebook API implementation in Perl
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-WWW-Mechanize-Shell/Makefile b/www/p5-WWW-Mechanize-Shell/Makefile
index da61b5746020..5c226694ae58 100644
--- a/www/p5-WWW-Mechanize-Shell/Makefile
+++ b/www/p5-WWW-Mechanize-Shell/Makefile
@@ -31,18 +31,13 @@ USE_PERL5= configure
DOCS= Changes README
EXAMPLES= banking.postbank.de.mech hotmail.signup.mech wwwshell.pl
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/bin && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR})
@${ECHO_MSG} "===> Documentation installed in ${EXAMPLESDIR}."
-.endif
.include <bsd.port.mk>
diff --git a/www/p5-WWW-NioTV/Makefile b/www/p5-WWW-NioTV/Makefile
index d1dc658ef728..47a401d0857d 100644
--- a/www/p5-WWW-NioTV/Makefile
+++ b/www/p5-WWW-NioTV/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WWW-NioTV
PORTVERSION= 0.04
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX=v
CATEGORIES= www perl5
MASTER_SITES= CPAN
@@ -16,8 +16,7 @@ BUILD_DEPENDS= p5-HTML-SimpleLinkExtor>=1.19:${PORTSDIR}/www/p5-HTML-SimpleLinkE
p5-HTML-TableExtract>=2.1:${PORTSDIR}/www/p5-HTML-TableExtract \
p5-List-MoreUtils>=0.22:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Moose>=0.54:${PORTSDIR}/devel/p5-Moose \
- p5-WWW-Mechanize>=1.34:${PORTSDIR}/www/p5-WWW-Mechanize \
- p5-version>=0.76:${PORTSDIR}/devel/p5-version
+ p5-WWW-Mechanize>=1.34:${PORTSDIR}/www/p5-WWW-Mechanize
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/www/p5-WebService-YouTube/Makefile b/www/p5-WebService-YouTube/Makefile
index 5bdc1e5c0b75..b159f7b14a31 100644
--- a/www/p5-WebService-YouTube/Makefile
+++ b/www/p5-WebService-YouTube/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WebService-YouTube
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,8 +17,7 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
p5-URI>0:${PORTSDIR}/net/p5-URI \
- p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
- p5-version>0:${PORTSDIR}/devel/p5-version
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5