aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile13
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx/Makefile13
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-ngx_http_subs_filter_module.c11
5 files changed, 16 insertions, 29 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index e4837013550c..0c800308f948 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -457,12 +457,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_VERSIO
.endif
.if ${PORT_OPTIONS:MHTTP_SUBS_FILTER}
-USE_HTTP_REWRITE= yes
-NGINX_HTTP_SUBS_FILTER_VERSION= 0.5.2.r59
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
-MASTER_SITE_SUBDIR+= osa/:subs_filter
-DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}
+GIT_HTTP_SUBS_FILTER_VERSION= 0-gb32237d
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/yaoweibin/ngx_http_substitutions_filter_module/tarball/master/:subs_filter
+DISTFILES+= yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION:S/^0-g//}
.endif
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
@@ -854,7 +853,7 @@ USE_OPENSSL= yes
pre-everything::
@${ECHO_MSG}
-.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR)
+.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR}
@${ECHO_MSG} "Enable http_ssl module to build upstream_fair with SSL support"
.endif
.if ${PORT_OPTIONS:MPASSENGER}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index f1155222698d..1b45233226ba 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -36,8 +36,8 @@ SHA256 (ngx_http_redis-0.3.6.tar.gz) = 9e5d8c0f1317a6910710c94d27f9aca4968c48ee1
SIZE (ngx_http_redis-0.3.6.tar.gz) = 12099
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
-SHA256 (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 8fd9a185f092320a5290ad8b9f19bf0f7499167db275990c7f0228cd9aefb6fe
-SIZE (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 95092
+SHA256 (yaoweibin-ngx_http_substitutions_filter_module-0-gb32237d.tar.gz) = f190a9bcf18f730a36e871aca52c0047291b7106d72da687889508be75b9afd6
+SIZE (yaoweibin-ngx_http_substitutions_filter_module-0-gb32237d.tar.gz) = 91778
SHA256 (nginx_upload_module-2.2.0.tar.gz) = b1c26abe0427180602e257627b4ed21848c93cc20cefc33af084983767d65805
SIZE (nginx_upload_module-2.2.0.tar.gz) = 25796
SHA256 (masterzen-nginx-upload-progress-module-v0.9.0-0-ga788dea.tar.gz) = 3fb903dab595cf6656fa0fc5743a48daffbba2f6b5c554836be630800eaad4e2
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 3db2547706e1..98b0e252cb9c 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -456,12 +456,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_VERSIO
.if ${PORT_OPTIONS:MHTTP_SUBS_FILTER}
USE_HTTP_REWRITE= yes
-NGINX_HTTP_SUBS_FILTER_VERSION= 0.5.2.r59
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
-MASTER_SITE_SUBDIR+= osa/:subs_filter
-DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_subs_filter_module.c
+GIT_HTTP_SUBS_FILTER_VERSION= 0-gb32237d
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/yaoweibin/ngx_http_substitutions_filter_module/tarball/master/:subs_filter
+DISTFILES+= yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION:S/^0-g//}
.endif
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
@@ -845,7 +844,7 @@ USE_OPENSSL= yes
pre-everything::
@${ECHO_MSG}
-.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR)
+.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR}
@${ECHO_MSG} "Enable http_ssl module to build upstream_fair with SSL support"
.endif
.if ${PORT_OPTIONS:MPASSENGER}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 3382f1ec521a..9f9989d73708 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -36,8 +36,8 @@ SHA256 (ngx_http_redis-0.3.6.tar.gz) = 9e5d8c0f1317a6910710c94d27f9aca4968c48ee1
SIZE (ngx_http_redis-0.3.6.tar.gz) = 12099
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
-SHA256 (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 8fd9a185f092320a5290ad8b9f19bf0f7499167db275990c7f0228cd9aefb6fe
-SIZE (ngx_http_subs_filter_module-0.5.2.r59.tar.gz) = 95092
+SHA256 (yaoweibin-ngx_http_substitutions_filter_module-0-gb32237d.tar.gz) = f190a9bcf18f730a36e871aca52c0047291b7106d72da687889508be75b9afd6
+SIZE (yaoweibin-ngx_http_substitutions_filter_module-0-gb32237d.tar.gz) = 91778
SHA256 (nginx_upload_module-2.2.0.tar.gz) = b1c26abe0427180602e257627b4ed21848c93cc20cefc33af084983767d65805
SIZE (nginx_upload_module-2.2.0.tar.gz) = 25796
SHA256 (masterzen-nginx-upload-progress-module-v0.9.0-0-ga788dea.tar.gz) = 3fb903dab595cf6656fa0fc5743a48daffbba2f6b5c554836be630800eaad4e2
diff --git a/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c b/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c
deleted file mode 100644
index c2e579f26420..000000000000
--- a/www/nginx/files/extra-patch-ngx_http_subs_filter_module.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../ngx_http_subs_filter_module-0.5.2.r59/ngx_http_subs_filter_module.c.orig 2012-07-03 20:55:52.000000000 +0400
-+++ ../ngx_http_subs_filter_module-0.5.2.r59/ngx_http_subs_filter_module.c 2012-07-03 20:56:52.000000000 +0400
-@@ -1302,7 +1302,7 @@
-
- n = 0;
-
--#if defined(nginx_version) && nginx_version >= 1003001
-+#if defined(nginx_version) && nginx_version >= 1002002
- rc = pcre_fullinfo(re->code, NULL, PCRE_INFO_CAPTURECOUNT, &n);
- #elif defined(nginx_version) && nginx_version >= 1001012
- rc = pcre_fullinfo(re->pcre, NULL, PCRE_INFO_CAPTURECOUNT, &n);