aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-jekyll/Makefile30
-rw-r--r--www/rubygem-jekyll/distinfo3
-rw-r--r--www/rubygem-jekyll/pkg-descr9
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 17dc95276552..32308f4543d3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1439,6 +1439,7 @@
SUBDIR += rubygem-htauth
SUBDIR += rubygem-httparty
SUBDIR += rubygem-httpclient
+ SUBDIR += rubygem-jekyll
SUBDIR += rubygem-layout-yullio
SUBDIR += rubygem-maruku
SUBDIR += rubygem-mechanize
diff --git a/www/rubygem-jekyll/Makefile b/www/rubygem-jekyll/Makefile
new file mode 100644
index 000000000000..224d65861f95
--- /dev/null
+++ b/www/rubygem-jekyll/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: jekyll
+# Date created: 2009-12-24
+# Whom: Peter Schuller <peter.schuller@infidyne.com>
+#
+# $FreeBSD$
+
+PORTNAME= jekyll
+PORTVERSION= 0.5.4
+CATEGORIES= www
+MASTER_SITES= http://gemcutter.org/gems/
+
+MAINTAINER= peter.schuller@infidyne.com
+COMMENT= A is a simple, blog aware, static site generator
+
+RUN_DEPENDS= rubygem-classifier>=1.3.1:${PORTSDIR}/devel/rubygem-classifier \
+ rubygem-redcloth>=4.2.1:${PORTSDIR}/www/rubygem-redcloth \
+ rubygem-liquid>=1.9.0:${PORTSDIR}/textproc/rubygem-liquid \
+ rubygem-maruku>=0.5.9:${PORTSDIR}/www/rubygem-maruku \
+ rubygem-directory_watcher>=1.1.1:${PORTSDIR}/devel/rubygem-directory_watcher \
+ rubygem-open4>=0.9.6:${PORTSDIR}/devel/rubygem-open4
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/jekyll
+
+# we care about not passing -A
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-jekyll/distinfo b/www/rubygem-jekyll/distinfo
new file mode 100644
index 000000000000..b17fd6a4abeb
--- /dev/null
+++ b/www/rubygem-jekyll/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/jekyll-0.5.4.gem) = 241031ed3594e811095d66620a721d63
+SHA256 (rubygem/jekyll-0.5.4.gem) = 4930e96a9530bb8d1e164adb4a374224709edf859182e93ddcf689e362dba8be
+SIZE (rubygem/jekyll-0.5.4.gem) = 36352
diff --git a/www/rubygem-jekyll/pkg-descr b/www/rubygem-jekyll/pkg-descr
new file mode 100644
index 000000000000..5c115bb683d6
--- /dev/null
+++ b/www/rubygem-jekyll/pkg-descr
@@ -0,0 +1,9 @@
+Jekyll is a simple, blog aware, static site generator. It takes a
+template directory (representing the raw form of a website), runs it
+through Textile or Markdown and Liquid converters, and spits out a
+complete, static website suitable for serving with Apache or your
+favorite web server. This is also the engine behind GitHub Pages,
+which you can use to host your project?s page or blog right here from
+GitHub.
+
+WWW: http://github.com/mojombo/jekyll