aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-restrictedarea/Makefile27
-rw-r--r--www/trac-restrictedarea/distinfo3
-rw-r--r--www/trac-restrictedarea/pkg-descr6
-rw-r--r--www/trac-restrictedarea/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 19b446c3027f..b39f52335142 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1163,6 +1163,7 @@
SUBDIR += trac-nav
SUBDIR += trac-pagetopdf
SUBDIR += trac-privatetickets
+ SUBDIR += trac-restrictedarea
SUBDIR += trac-robotstxt
SUBDIR += trac-tags
SUBDIR += trac-tocmacro
diff --git a/www/trac-restrictedarea/Makefile b/www/trac-restrictedarea/Makefile
new file mode 100644
index 000000000000..a924d6f6b20a
--- /dev/null
+++ b/www/trac-restrictedarea/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trac-restrictedarea
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= restrictedarea
+PORTVERSION= 1.0.0
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Set up restricted areas within Trac
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/trac-restrictedarea/distinfo b/www/trac-restrictedarea/distinfo
new file mode 100644
index 000000000000..c52079cbbea4
--- /dev/null
+++ b/www/trac-restrictedarea/distinfo
@@ -0,0 +1,3 @@
+MD5 (restrictedareaplugin-1.0.0.tar.gz) = c444875742312e2d42b012ea8f027aa4
+SHA256 (restrictedareaplugin-1.0.0.tar.gz) = 0082d6e4fb4417476affcadab32f2c6b078feca68c77c97c068063881797d5bc
+SIZE (restrictedareaplugin-1.0.0.tar.gz) = 1188
diff --git a/www/trac-restrictedarea/pkg-descr b/www/trac-restrictedarea/pkg-descr
new file mode 100644
index 000000000000..f61cf66232c1
--- /dev/null
+++ b/www/trac-restrictedarea/pkg-descr
@@ -0,0 +1,6 @@
+The RestrictedAreaPlugin is a pretty simple Trac plugin that allows the Trac
+administrator to set up restricted areas which are accessible only for
+privileged users. The access is controlled via the new Trac action
+RESTRICTED_AREA_ACCESS and a list of paths configured in the Trac INI-file.
+
+WWW: http://trac-hacks.org/wiki/RestrictedAreaPlugin
diff --git a/www/trac-restrictedarea/pkg-plist b/www/trac-restrictedarea/pkg-plist
new file mode 100644
index 000000000000..cb5f059b1f01
--- /dev/null
+++ b/www/trac-restrictedarea/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracRestrictedArea-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg