aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/Makefile12
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/distinfo6
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/files/500503-lib_POE_Component_Server_SimpleHTTP.pm38
3 files changed, 6 insertions, 50 deletions
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/Makefile b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
index 2b5d304fc203..3a089caa233a 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/Makefile
+++ b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= POE-Component-Server-SimpleHTTP
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= POE
@@ -40,14 +40,8 @@ BUILD_DEPENDS+= ${SITE_PERL}/POE/Component/SSLify.pm:${PORTSDIR}/security/p5-POE
BUILD_DEPENDS+= ${SITE_PERL}/IPC/Shareable.pm:${PORTSDIR}/devel/p5-IPC-Shareable
.endif
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${FILESDIR}/500503-*
-
-post-patch:
- @${PERL} -pi -e 's/^our ([\$$\@]\w+)/use vars qw($$1); $$1/;' \
- -e '$$_ = "" if /use warnings/;' \
- $$(${FIND} ${WRKSRC} -name '*.pm')
- @${RM} ${WRKSRC}/lib/POE/Component/Server/SimpleHTTP.pm.orig
+.if ${PERL_LEVEL} < 500600 # inherited from www/p5-libwww
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/distinfo b/www/p5-POE-Component-Server-SimpleHTTP/distinfo
index 844e7684dcbc..4946a612f746 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/distinfo
+++ b/www/p5-POE-Component-Server-SimpleHTTP/distinfo
@@ -1,3 +1,3 @@
-MD5 (POE-Component-Server-SimpleHTTP-1.11.tar.gz) = dec01e04284b5acda6d706018b1f499c
-SHA256 (POE-Component-Server-SimpleHTTP-1.11.tar.gz) = 5fe995600079ab3ef5c34b81a43658e9b8370fd0bd57af1fa38d50c6c2c92b80
-SIZE (POE-Component-Server-SimpleHTTP-1.11.tar.gz) = 22041
+MD5 (POE-Component-Server-SimpleHTTP-1.12.tar.gz) = ad0138873d0824de9fce0ba150160579
+SHA256 (POE-Component-Server-SimpleHTTP-1.12.tar.gz) = 59661d17c45f423176c1749915575d2b48b15e276fcc74a0a5daa2c8c42e4447
+SIZE (POE-Component-Server-SimpleHTTP-1.12.tar.gz) = 22148
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/files/500503-lib_POE_Component_Server_SimpleHTTP.pm b/www/p5-POE-Component-Server-SimpleHTTP/files/500503-lib_POE_Component_Server_SimpleHTTP.pm
deleted file mode 100644
index 929e1815d4a6..000000000000
--- a/www/p5-POE-Component-Server-SimpleHTTP/files/500503-lib_POE_Component_Server_SimpleHTTP.pm
+++ /dev/null
@@ -1,38 +0,0 @@
---- lib/POE/Component/Server/SimpleHTTP.pm.orig Wed Oct 12 14:07:14 2005
-+++ lib/POE/Component/Server/SimpleHTTP.pm Wed Oct 12 14:08:57 2005
-@@ -542,7 +542,7 @@
- }
-
- # Destroy this wheel!
-- delete $_[HEAP]->{'REQUESTS'}->{ $id }->[0];
-+ $_[HEAP]->{'REQUESTS'}->{ $id }->[0] = undef;
- delete $_[HEAP]->{'REQUESTS'}->{ $id };
-
- # All done!
-@@ -614,7 +614,7 @@
- # Check if the SimpleHTTP::Connection object croaked ( happens when sockets just disappear )
- if ( ! defined $response->{'CONNECTION'} ) {
- # Destroy this wheel!
-- delete $_[HEAP]->{'REQUESTS'}->{ $id }->[0];
-+ $_[HEAP]->{'REQUESTS'}->{ $id }->[0] = undef;
- delete $_[HEAP]->{'REQUESTS'}->{ $id };
-
- # All done!
-@@ -671,7 +671,7 @@
-
- # Delete the wheel
- # Tracked down by Paul Visscher
-- delete $_[HEAP]->{'REQUESTS'}->{ $id }->[0];
-+ $_[HEAP]->{'REQUESTS'}->{ $id }->[0] = undef;
- delete $_[HEAP]->{'REQUESTS'}->{ $id };
- } else {
- # Ignore this, eh?
-@@ -823,7 +823,7 @@
- }
-
- # Delete it!
-- delete $_[HEAP]->{'REQUESTS'}->{ $id }->[0];
-+ $_[HEAP]->{'REQUESTS'}->{ $id }->[0] = undef;
- delete $_[HEAP]->{'REQUESTS'}->{ $id };
-
- # All done!