aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/input-wacom
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/input-wacom')
-rw-r--r--x11-drivers/input-wacom/Makefile37
-rw-r--r--x11-drivers/input-wacom/files/patch-linuxwacom-run_configure16
-rw-r--r--x11-drivers/input-wacom/pkg-descr3
3 files changed, 23 insertions, 33 deletions
diff --git a/x11-drivers/input-wacom/Makefile b/x11-drivers/input-wacom/Makefile
index 7af3852fd706..37b71cf507e3 100644
--- a/x11-drivers/input-wacom/Makefile
+++ b/x11-drivers/input-wacom/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://www.chillt.de/bsdwacom/:bsdwacom \
SF/linuxwacom/linuxwacom/${WACOM_VERSION}:linuxwacom
DISTFILES= ${BSDWACOM}.tbz:bsdwacom \
${LINUXWACOM}.tar.bz2:linuxwacom
+EXTRACT_ONLY= ${BSDWACOM}.tbz
MAINTAINER= kamikaze@bsdforen.de
COMMENT= X.Org Wacom tablet driver and kernel module
@@ -22,7 +23,6 @@ MANCOMPRESSED= yes
USE_GMAKE= yes
USE_RC_SUBR= wacom
-USE_LDCONFIG= no
KMODDIR?= /boot/modules
XINPUTMODDIR= lib/xorg/modules/input
@@ -44,18 +44,20 @@ BSDWACOM= bsdwacom-${KLD_VERSION}
WACOM_VERSION= 0.8.2-2
KLD_VERSION= 40
-OPTIONS= UWACOMKLD "Install USB kernel module (ignored on 8.x)" ${KMOD_SUPPORTED}
-
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 800064
-KMOD_SUPPORTED= Off
-.undef WITH_UWACOMKLD
+OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" Off
.else
-KMOD_SUPPORTED= On
+OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" On
.endif
+.include <bsd.port.options.mk>
+
.if defined(WITH_UWACOMKLD)
+.if ${OSVERSION} >= 800064
+BROKEN= does not build with USB support
+.endif
PLIST_SUB+= UWACOMKLD="uwacom.ko"
PORTTYPE= usb
.else
@@ -63,22 +65,17 @@ PLIST_SUB+= UWACOMKLD="@noinst UWACOMKLD uwacom.ko"
PORTTYPE= serial
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
-post-patch:
- @${LN} -s ../${LINUXWACOM} ${WRKDIR}/linuxwacom/
-
do-configure:
- @cd ${WRKDIR}/linuxwacom && ${SETENV} ${MAKE_ENV} ./run_configure
+ @cd ${WRKDIR}/linuxwacom \
+ && ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/${LINUXWACOM}.tar.bz2 \
+ && ${SETENV} ${MAKE_ENV} ./run_configure
do-build:
.if defined(WITH_UWACOMKLD)
@cd ${WRKDIR}/uwacom \
&& ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS}
.endif
- @cd ${WRKDIR}/${LINUXWACOM} \
+ @cd ${WRKDIR}/linuxwacom/${LINUXWACOM} \
&& ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS}
do-install:
@@ -88,7 +85,7 @@ do-install:
.endif
@${MKDIR} ${PREFIX}/${XINPUTMODDIR} ${PREFIX}/${MAN4DIR}
@cd ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/util/ \
- && ${SETENV} ${MAKE_ENV} ${GMAKE} ${INSTALL_TARGET}
+ && ${SETENV} ${MAKE_ENV} ${GMAKE} install
@${INSTALL} ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/xdrv/wacom_drv.so \
${PREFIX}/${XINPUTMODDIR}/
@${INSTALL_MAN} ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/wacom.4x.gz \
@@ -101,8 +98,8 @@ plist: clean configure
@cd ${WRKDIR}/linuxwacom \
&& ${SETENV} ${MAKE_ENV} PREFIX=${WRKDIR}/plist ./run_configure
@${MKDIR} ${WRKDIR}/plist
- @cd ${WRKDIR}/${LINUXWACOM}/src/util \
- && ${SETENV} ${MAKE_ENV} ${GMAKE} ${INSTALL_TARGET}
+ @cd ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/util \
+ && ${SETENV} ${MAKE_ENV} ${GMAKE} install
@cd ${WRKDIR}/linuxwacom \
&& ${SETENV} ${MAKE_ENV} ./run_configure
@${FIND} ${WRKDIR}/plist/ -not -type d \
@@ -120,4 +117,4 @@ post-install:
@${ECHO} "===> Displaying pkg-message."
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure b/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure
index ed6a08602df8..2f4dccc9f09e 100644
--- a/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure
+++ b/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure
@@ -1,21 +1,17 @@
---- linuxwacom/run_configure.orig 2008-12-26 02:09:57.000000000 +0100
-+++ linuxwacom/run_configure 2010-05-13 22:44:05.000000000 +0200
-@@ -1,10 +1,8 @@
+--- linuxwacom/run_configure.orig 2009-01-21 11:26:52.000000000 +0100
++++ linuxwacom/run_configure 2009-01-21 11:27:00.000000000 +0100
+@@ -1,7 +1,7 @@
#!/bin/sh
# $Id: run_configure 40 2008-12-26 01:08:35Z undo $
-LINUXWACOM=0.8.2
+LINUXWACOM=0.8.2-2
--rm -rf linuxwacom-${LINUXWACOM}
--tar xf linuxwacom-${LINUXWACOM}.tar.bz2
- mkdir linuxwacom-${LINUXWACOM}/src/util/asm
- mkdir linuxwacom-${LINUXWACOM}/src/util/linux
- mkdir linuxwacom-${LINUXWACOM}/src/xdrv/asm
-@@ -14,5 +12,5 @@
+ rm -rf linuxwacom-${LINUXWACOM}
+ tar xf linuxwacom-${LINUXWACOM}.tar.bz2
+@@ -14,5 +14,5 @@
cp files/types.h linuxwacom-${LINUXWACOM}/src/xdrv/asm
cp files/input.h linuxwacom-${LINUXWACOM}/src/xdrv/linux
cd linuxwacom-${LINUXWACOM}
-./configure --with-linux=yes --with-tcl=/usr/local/include/tcl8.4 --with-tk=/usr/local/include/tk8.4 --prefix=${PREFIX} --enable-dlloader CFLAGS="-I/usr/local/include"
+./configure --with-linux=yes --with-tcl=/usr/local/include/tcl8.4 --with-tk=/usr/local/include/tk8.4 --prefix=${PREFIX} --enable-dlloader CFLAGS="-I/usr/local/include -DWCM_XORG_XSERVER_1_6=true"
-
diff --git a/x11-drivers/input-wacom/pkg-descr b/x11-drivers/input-wacom/pkg-descr
index 9d5c1d0ab7f1..228b6cf6f412 100644
--- a/x11-drivers/input-wacom/pkg-descr
+++ b/x11-drivers/input-wacom/pkg-descr
@@ -12,6 +12,3 @@ supports the following devices:
* not tested
WWW: http://linuxwacom.sourceforge.net/
-
-- Kamikaze
-kamikaze@bsdforen.de