aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/cfm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/cfm/Makefile')
-rw-r--r--x11-fm/cfm/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-fm/cfm/Makefile b/x11-fm/cfm/Makefile
new file mode 100644
index 000000000000..73ae502f70e3
--- /dev/null
+++ b/x11-fm/cfm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: cfm
+# Date created: 23 June 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfm
+PORTVERSION= 0.5
+CATEGORIES= x11-fm
+MASTER_SITES= http://www.rpi.edu/~mullr/cfm/dist/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+post-patch:
+ @${PERL} -pi -e 's|#!/usr/bin/perl|#!${PERL}|' ${WRKSRC}/cfm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cfm ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/examples/cfm
+ ${INSTALL_DATA} ${WRKSRC}/example.cfmrc \
+ ${PREFIX}/share/examples/cfm/dot.cfmrc
+
+.include <bsd.port.mk>