aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/entropyfm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/entropyfm/Makefile')
-rw-r--r--x11-fm/entropyfm/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-fm/entropyfm/Makefile b/x11-fm/entropyfm/Makefile
new file mode 100644
index 000000000000..8a163f8f100a
--- /dev/null
+++ b/x11-fm/entropyfm/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: entropy
+# Date created: 2006-08-14
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= entropyfm
+PORTVERSION= 20060926
+CATEGORIES= x11-fm
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+DISTNAME= ${PORTNAME:S,fm$,,}-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= An EFL-based file manager
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_EFL= ecore etk ewl evfs imlib2 epsilon
+GNU_CONFIGURE= yes
+
+CFLAGS+= "-L${LOCALBASE}/lib"
+
+OPTIONS= XTRACT "Enable metadata extraction via libextractor" on \
+ PNG "Enable png thumbnailing" on
+
+DATADIR= ${PREFIX}/share/entropy
+
+.include <bsd.port.pre.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+
+.if !defined(WITHOUT_XTRACT)
+LIB_DEPENDS+= extractor.2:${PORTSDIR}/textproc/libextractor
+CONFIGURE_ARGS+=--enable-plugin-extractor
+PLIST_SUB+= EXTRACT=""
+.else
+CONFIGURE_ARGS+=--disable-plugin-extractor
+PLIST_SUB+= EXTRACT="@comment "
+.endif
+
+.if !defined(WITHOUT_PNG) || exists(${LOCALBASE}/lib/libpng.so.5)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.endif
+
+.include <bsd.port.post.mk>