aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/nautilus/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/nautilus/files')
-rw-r--r--x11-fm/nautilus/files/patch-aa100
-rw-r--r--x11-fm/nautilus/files/patch-ab13
-rw-r--r--x11-fm/nautilus/files/patch-ac152
-rw-r--r--x11-fm/nautilus/files/patch-ad30
-rw-r--r--x11-fm/nautilus/files/patch-ae10
-rw-r--r--x11-fm/nautilus/files/patch-af11
-rw-r--r--x11-fm/nautilus/files/patch-ag13
7 files changed, 329 insertions, 0 deletions
diff --git a/x11-fm/nautilus/files/patch-aa b/x11-fm/nautilus/files/patch-aa
new file mode 100644
index 000000000000..ff17f0b7066d
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-aa
@@ -0,0 +1,100 @@
+--- configure.orig Mon Aug 14 19:47:02 2000
++++ configure Mon Aug 28 13:34:38 2000
+@@ -2368,7 +2368,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpam -ldl $LIBS"
++LIBS="-lpam $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2374 "configure"
+ #include "confdefs.h"
+@@ -2408,7 +2408,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpam_misc -ldl -lpam $LIBS"
++LIBS="-lpam_misc -lpam $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2414 "configure"
+ #include "confdefs.h"
+@@ -2436,10 +2436,10 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- PAM_LIBS="-ldl -lpam -lpam_misc"
++ PAM_LIBS="-lpam -lpam_misc"
+ else
+ echo "$ac_t""no" 1>&6
+-PAM_LIBS="-ldl -lpam"
++PAM_LIBS="-lpam"
+ fi
+
+ else
+@@ -2657,7 +2657,7 @@
+
+ CC=$_save_cc
+
+-LDFLAGS="$_save_cflags -L$_mozilla_lib_place $_mozilla_all_nspr_flags -lgtksuperwin"
++LDFLAGS="$_save_cflags -L$_mozilla_lib_place $_mozilla_all_nspr_flags -lstdc++ -lgtksuperwin"
+ echo $ac_n "checking for gdk_superwin_get_type in -lgtksuperwin""... $ac_c" 1>&6
+ echo "configure:2663: checking for gdk_superwin_get_type in -lgtksuperwin" >&5
+ ac_lib_var=`echo gtksuperwin'_'gdk_superwin_get_type | sed 'y%./+-%__p_%'`
+@@ -2979,7 +2979,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- rpm_libs=-lbz2
++ rpm_libs="-lrpm -lbz2"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+@@ -3019,7 +3019,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- rpm_libs=-lbz2
++ rpm_libs="-lrpm -lbz2"
+ cat >> confdefs.h <<\EOF
+ #define bzread BZ2_bzread
+ EOF
+@@ -3109,24 +3109,24 @@
+ echo "$ac_t""no" 1>&6
+ fi
+
+-echo $ac_n "checking for rpmRunTransactions in -lrpm""... $ac_c" 1>&6
+-echo "configure:3114: checking for rpmRunTransactions in -lrpm" >&5
+-ac_lib_var=`echo rpm'_'rpmRunTransactions | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for rpmReadPackageInfo in -lrpm""... $ac_c" 1>&6
++echo "configure:3114: checking for rpmReadPackageInfo in -lrpm" >&5
++ac_lib_var=`echo rpm'_'rpmReadPackageInfo | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lrpm -lz $rpm_libs -ldb $LIBS"
++LIBS="-lrpm -lz $rpm_libs $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3122 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char rpmRunTransactions();
++char rpmReadPackageInfo();
+
+ int main() {
+-rpmRunTransactions()
++rpmReadPackageInfo()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:3133: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -3156,7 +3156,7 @@
+ #define HAVE_RPM 1
+ EOF
+
+- RPM_LIBS="-lrpm -lz $rpm_libs -ldb"
++ RPM_LIBS="-lrpm -lz $rpm_libs"
+ fi
+
+
diff --git a/x11-fm/nautilus/files/patch-ab b/x11-fm/nautilus/files/patch-ab
new file mode 100644
index 000000000000..a46aeaaf19d8
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-ab
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Wed Aug 16 08:26:30 2000
++++ Makefile.in Wed Aug 23 14:56:45 2000
+@@ -501,8 +501,8 @@
+ $(mkinstalldirs) $(DESTDIR)/$(prefix)/bin
+ @list='nautilus-clean.sh'; for p in $$list; do\
+ if test -f $(srcdir)/$$p; then \
+- echo " $(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p"; \
+- $(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
++ echo " $(INSTALL_SCRIPT) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p"; \
++ $(INSTALL_SCRIPT) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
+ else :; fi; \
+ done
+
diff --git a/x11-fm/nautilus/files/patch-ac b/x11-fm/nautilus/files/patch-ac
new file mode 100644
index 000000000000..708c7d4175cd
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-ac
@@ -0,0 +1,152 @@
+--- libnautilus-extensions/nautilus-volume-monitor.c.orig Thu Aug 3 17:15:57 2000
++++ libnautilus-extensions/nautilus-volume-monitor.c Tue Aug 22 17:45:07 2000
+@@ -22,6 +22,9 @@
+ Authors: Gene Z. Ragan <gzr@eazel.com>
+ */
+
++#include <sys/param.h>
++#include <sys/mount.h>
++
+ #include <config.h>
+
+ #include <errno.h>
+@@ -31,7 +34,6 @@
+ #include <gnome.h>
+ #include <libgnome/gnome-i18n.h>
+ #include <libgnomevfs/gnome-vfs.h>
+-#include <mntent.h>
+ #include <libnautilus-extensions/nautilus-cdrom-extensions.h>
+ #include <libnautilus-extensions/nautilus-directory-private.h>
+ #include <libnautilus-extensions/nautilus-file-utilities.h>
+@@ -48,6 +50,11 @@
+ #include <sys/types.h>
+ #include <xmlmemory.h>
+
++#undef MOUNT_TYPE_ISO9660
++#define MOUNT_TYPE_ISO9660 "cd9660"
++#undef MOUNT_TYPE_EXT2
++#define MOUNT_TYPE_EXT2 "ufs" /* really ufs */
++#define _PATH_MOUNTED "/etc/fstab"
+
+ /* FIXME: Remove messages when this code is done. */
+ #define MESSAGE g_message
+@@ -91,7 +98,7 @@
+ DeviceInfo *device);
+ static void mount_device_activate_floppy (NautilusVolumeMonitor *view,
+ DeviceInfo *device);
+-static gboolean mntent_is_removable_fs (struct mntent *ent);
++static gboolean mntent_is_removable_fs (struct fstab *ent);
+ static void free_device_info (DeviceInfo *device,
+ NautilusVolumeMonitor *monitor);
+ static gboolean add_mount_link_property (const char *path);
+@@ -197,21 +204,19 @@
+ fm_desktop_get_removable_volume_list (void)
+ {
+ GList *list;
+- FILE *mef;
+- struct mntent *ent;
++ struct fstab *ent;
+
+ list = NULL;
+
+- mef = setmntent (_PATH_FSTAB, "r");
+- g_return_val_if_fail (mef, NULL);
++ setfsent();
+
+- while ((ent = getmntent (mef))) {
++ while ((ent = getfsent ())) {
+ if (mntent_is_removable_fs (ent)) {
+- list = g_list_append (list, g_strdup (ent->mnt_dir));
++ list = g_list_append (list, g_strdup (ent->fs_file));
+ continue;
+ }
+ }
+- endmntent (mef);
++ endfsent ();
+
+ /* Move all floppy mounts to top of list */
+ list = g_list_sort (list, (GCompareFunc) floppy_sort);
+@@ -754,7 +759,7 @@
+
+
+ static void
+-add_mount_device (NautilusVolumeMonitor *monitor, struct mntent *ent)
++add_mount_device (NautilusVolumeMonitor *monitor, struct fstab *ent)
+ {
+ DeviceInfo *newdev = NULL;
+ gboolean mounted;
+@@ -762,23 +767,23 @@
+ newdev = g_new0 (DeviceInfo, 1);
+ g_assert (newdev);
+ newdev->device_fd = -1;
+- newdev->fsname = g_strdup (ent->mnt_fsname);
+- newdev->mount_path = g_strdup (ent->mnt_dir);
++ newdev->fsname = g_strdup (ent->fs_spec);
++ newdev->mount_path = g_strdup (ent->fs_file);
+ newdev->volume_name = NULL;
+ newdev->link_uri = NULL;
+ newdev->state = STATE_EMPTY;
+
+ mounted = FALSE;
+
+- if (strcmp (ent->mnt_type, MOUNT_TYPE_ISO9660) == 0) {
++ if (strcmp (ent->fs_type, MOUNT_TYPE_ISO9660) == 0) {
+ mounted = mount_device_iso9660_add (monitor, newdev);
+- } else if (strncmp (ent->mnt_fsname, "/dev/fd", strlen("/dev/fd")) == 0) {
++ } else if (strncmp (ent->fs_file, "/dev/fd", strlen("/dev/fd")) == 0) {
+ mounted = mount_device_floppy_add (monitor, newdev);
+- } else if (strcmp (ent->mnt_type, MOUNT_TYPE_EXT2) == 0) {
++ } else if (strcmp (ent->fs_type, MOUNT_TYPE_EXT2) == 0) {
+ mounted = mount_device_ext2_add (newdev);
+ } else {
+ /* FIXME: Is this a reasonable way to report this error? */
+- MESSAGE ("Unknown file system: %s", ent->mnt_type);
++ MESSAGE ("Unknown file system: %s", ent->fs_type);
+ }
+
+ if (mounted) {
+@@ -794,13 +799,13 @@
+ }
+
+ static gboolean
+-mntent_is_removable_fs (struct mntent *ent)
++mntent_is_removable_fs (struct fstab *ent)
+ {
+- if (strcmp (ent->mnt_type, MOUNT_TYPE_ISO9660) == 0) {
++ if (strcmp (ent->fs_type, MOUNT_TYPE_ISO9660) == 0) {
+ return TRUE;
+ }
+
+- if (strncmp (ent->mnt_fsname, "/dev/fd", strlen("/dev/fd")) == 0) {
++ if (strncmp (ent->fs_file, "/dev/fd", strlen("/dev/fd")) == 0) {
+ return TRUE;
+ }
+
+@@ -833,14 +838,12 @@
+ void
+ nautilus_volume_monitor_find_mount_devices (NautilusVolumeMonitor *monitor)
+ {
+- FILE *mef;
+- struct mntent *ent;
++ struct fstab *ent;
+
+- mef = setmntent (_PATH_MNTTAB, "r");
+- g_return_if_fail (mef);
++ setfsent ();
+
+- while ((ent = getmntent (mef))) {
+- MESSAGE ("Checking device %s", ent->mnt_fsname);
++ while ((ent = getfsent ())) {
++ MESSAGE ("Checking device %s", ent->fs_spec);
+
+ #if 0
+ /* Think some more about these checks */
+@@ -859,7 +862,7 @@
+ }
+
+
+- endmntent (mef);
++ endfsent ();
+
+ g_list_foreach (monitor->details->devices, (GFunc) mount_device_set_state, monitor);
+
diff --git a/x11-fm/nautilus/files/patch-ad b/x11-fm/nautilus/files/patch-ad
new file mode 100644
index 000000000000..5f1fee5478fb
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-ad
@@ -0,0 +1,30 @@
+--- components/rpmview/nautilus-rpm-view.c.orig Mon Aug 7 18:31:00 2000
++++ components/rpmview/nautilus-rpm-view.c Tue Aug 22 18:21:25 2000
+@@ -52,6 +52,10 @@
+ #include <libgnorba/gnorba.h>
+ #include <limits.h>
+
++#define FD_t int
++#define fdOpen open
++#define fdClose close
++
+ #ifdef EAZEL_SERVICES
+ #include <libeazelinstall.h>
+ #include "nautilus-rpm-view-install.h"
+@@ -399,7 +403,6 @@
+ gint result = 0;
+ gchar *version_ptr, *release_ptr;
+
+- rpmReadConfigFiles (NULL, NULL);
+ rpm_result = rpmdbOpen ("", &rpm_db, O_RDONLY, 0644);
+ if (rpm_result != 0) {
+ g_message ("couldn't open package database: %d", rpm_result);
+@@ -467,7 +470,7 @@
+
+ file_descriptor = fdOpen (path_name, O_RDONLY, 0644);
+
+- if (file_descriptor != NULL) {
++ if (file_descriptor != -1) {
+
+ /* read out the appropriate fields, and set them up in the view */
+ result = rpmReadPackageInfo (file_descriptor, &signature, &header_info);
diff --git a/x11-fm/nautilus/files/patch-ae b/x11-fm/nautilus/files/patch-ae
new file mode 100644
index 000000000000..5feacc5b592c
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-ae
@@ -0,0 +1,10 @@
+--- src/file-manager/fm-desktop-icon-view.c.orig Thu Aug 3 17:15:58 2000
++++ src/file-manager/fm-desktop-icon-view.c Tue Aug 22 18:55:18 2000
+@@ -41,7 +41,6 @@
+ #include <libnautilus-extensions/nautilus-link.h>
+ #include <libnautilus-extensions/nautilus-volume-monitor.h>
+ #include <limits.h>
+-#include <mntent.h>
+ #include <stddef.h>
+ #include <stdio.h>
+ #include <string.h>
diff --git a/x11-fm/nautilus/files/patch-af b/x11-fm/nautilus/files/patch-af
new file mode 100644
index 000000000000..f5c2357db171
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-af
@@ -0,0 +1,11 @@
+--- tools/Makefile.in.orig Wed Aug 16 08:29:15 2000
++++ tools/Makefile.in Thu Aug 24 10:35:27 2000
+@@ -154,7 +154,7 @@
+
+ NULL =
+
+-SUBDIRS = leak-checker $(NULL)
++SUBDIRS = $(NULL)
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
diff --git a/x11-fm/nautilus/files/patch-ag b/x11-fm/nautilus/files/patch-ag
new file mode 100644
index 000000000000..b8000d55cb57
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-ag
@@ -0,0 +1,13 @@
+--- src/Makefile.in.orig Wed Aug 16 08:29:06 2000
++++ src/Makefile.in Wed Aug 23 14:53:30 2000
+@@ -573,8 +573,8 @@
+ $(mkinstalldirs) $(DESTDIR)/$(prefix)/bin
+ @list='run-nautilus'; for p in $$list; do\
+ if test -f $(srcdir)/$$p; then \
+- echo " $(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p"; \
+- $(INSTALL_PROGRAM) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
++ echo " $(INSTALL_SCRIPT) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p"; \
++ $(INSTALL_SCRIPT) $(srcdir)/$$p $(DESTDIR)/$(prefix)/bin/$$p; \
+ else :; fi; \
+ done
+