aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/pcmanfm-qt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/pcmanfm-qt/Makefile')
-rw-r--r--x11-fm/pcmanfm-qt/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-fm/pcmanfm-qt/Makefile b/x11-fm/pcmanfm-qt/Makefile
new file mode 100644
index 000000000000..b254bb350940
--- /dev/null
+++ b/x11-fm/pcmanfm-qt/Makefile
@@ -0,0 +1,26 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= pcmanfm-qt
+PORTVERSION= 0.11.1
+CATEGORIES= x11-fm
+MASTER_SITES= LXQT/${PORTNAME}
+DIST_SUBDIR= lxqt
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= LXQt file manager
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
+ libfm.so:x11/libfm
+
+USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
+ gettext-runtime localbase lxqt pkgconfig tar:xz
+USE_QT5= buildtools_build qmake_build core dbus gui widgets \
+ x11extras
+USE_LXQT= lxqt libfmqt
+USE_GNOME= glib20
+USE_XORG= xcb
+
+.include <bsd.port.mk>