aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/vide/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/vide/Makefile')
-rw-r--r--x11-fm/vide/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/x11-fm/vide/Makefile b/x11-fm/vide/Makefile
index e5a9677b993a..41967b21694e 100644
--- a/x11-fm/vide/Makefile
+++ b/x11-fm/vide/Makefile
@@ -14,10 +14,18 @@ MAINTAINER= careilly@thecia.ie
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-CFLAGS+= -DHAVE_SYS_PARAM_H
-MANCOMPRESSED= yes
-USE_XLIB= yes
-GNU_CONFIGURE= yes
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-DHAVE_SYS_PARAM_H" \
+ GTK_CONFIG="${GTK_CONFIG}"
+CONFIGURE_ARGS= --disable-gtktest
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/*.c
.include <bsd.port.mk>