aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/worker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/worker/Makefile')
-rw-r--r--x11-fm/worker/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index 3299b9047d1b..c15790435829 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= worker
-PORTVERSION= 3.5.2
+PORTVERSION= 3.6.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/cms/worker/downloads/
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= mp39590@gmail.com
COMMENT= X11 File Manager based on Directory Opus
@@ -16,21 +15,25 @@ RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
USE_XORG= x11
-USE_GCC= yes
USES= shebangfix tar:bzip2
SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor
-CFLAGS+= ${PTHREAD_CFLAGS}
-
-OPTIONS_DEFINE= XFT
+OPTIONS_DEFINE= XFT AVFS
+AVFS_DESC= Use AVFS library to access an archives
+AVFS_LIB_DEPENDS= libavfs.so:${PORTSDIR}/sysutils/avfs
XFT_CONFIGURE_ENABLE= xft
XFT_USE= XORG=xft
-pre-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000024
+USE_GCC= 4.6+
+.else
+CONFIGURE_ARGS+= --disable-cxx-check
+CXXFLAGS+= -std=c++11
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>