aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/xfce4-fm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/xfce4-fm/Makefile')
-rw-r--r--x11-fm/xfce4-fm/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/x11-fm/xfce4-fm/Makefile b/x11-fm/xfce4-fm/Makefile
index a08efa33ed82..6f3dfa925c92 100644
--- a/x11-fm/xfce4-fm/Makefile
+++ b/x11-fm/xfce4-fm/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= xfce4-fm
-PORTVERSION= 4.0.6
-PORTREVISION= 1
+PORTVERSION= 4.2.0
+PORTREVISION= 0
CATEGORIES= x11-fm xfce
-MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/${PORTVERSION}/ \
- http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PORTVERSION}/src/
+MASTER_SITES= http://www.us.xfce.org/archive/xfce-${PORTVERSION}/src/ \
+ http://spuriousinterrupt.org/projects/xfce4/files/mirror/xfce-${PORTVERSION}/ \
+ http://public.fh-wolfenbuettel.de/~luedickj/xfce4/xfce-${PORTVERSION}/
DISTNAME= xffm-${PORTVERSION}
DIST_SUBDIR= xfce4
@@ -21,14 +22,14 @@ BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
LIB_DEPENDS= dbh-1.0.1:${PORTSDIR}/databases/dbh \
xml2.5:${PORTSDIR}/textproc/libxml2 \
xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+ xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
@@ -37,6 +38,13 @@ CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
MAN1= fgr.1
+.if defined(WITH_LIBRSVG)
+USE_GNOME+= librsvg2
+CONFIGURE_ARGS+=--enable-librsvg
+.else
+CONFIGURE_ARGS+=--disable-librsvg
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/src/Makefile.in