aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/libXft/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/libXft/Makefile')
-rw-r--r--x11-fonts/libXft/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
new file mode 100644
index 000000000000..ce57e8addf6e
--- /dev/null
+++ b/x11-fonts/libXft/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Xft
+# Date created: 06 October 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Xft
+PORTVERSION= 2.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://fontconfig.org/release/
+DISTNAME= fcpackage.${PORTVERSION:S/./_/}
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+WRKSRC= ${WRKDIR}/${DISTNAME}/Xft
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>