aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/liberation-fonts-ttf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts/liberation-fonts-ttf/Makefile')
-rw-r--r--x11-fonts/liberation-fonts-ttf/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/x11-fonts/liberation-fonts-ttf/Makefile b/x11-fonts/liberation-fonts-ttf/Makefile
index f74fd01569ca..fe7803e89390 100644
--- a/x11-fonts/liberation-fonts-ttf/Makefile
+++ b/x11-fonts/liberation-fonts-ttf/Makefile
@@ -2,29 +2,40 @@
# $FreeBSD$
PORTNAME= liberation-fonts-ttf
-PORTVERSION= 2.00.1
+PORTVERSION= 2.00.3
PORTEPOCH= 2
CATEGORIES= x11-fonts
-MASTER_SITES= https://releases.pagure.org/liberation-fonts/ \
- LOCAL/thierry
MAINTAINER= thierry@FreeBSD.org
COMMENT= Liberation fonts from Red Hat to replace MS TTF fonts
LICENSE= OFL11
-USES= fonts
+BUILD_DEPENDS= fontforge:print/fontforge \
+ fonttools-3.6:print/py-fonttools@py36
+
+USE_GITHUB= yes
+GH_ACCOUNT= liberationfonts
+GH_PROJECT= liberation-fonts
+
+USES= fonts gmake python:3.3+,build
USE_XORG= x11
+NO_ARCH= yes
SUB_FILES= pkg-message
+SCRIPT_F= scripts/setisFixedPitch-fonttools.py
+
FONTNAME= Liberation
-INSTDAT= AUTHORS
-NO_BUILD= yes
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/${MAKEFILE}
+ ${REINPLACE_CMD} -e 's|/usr/bin/python3| ${PYTHON_CMD}|' \
+ ${WRKSRC}/${SCRIPT_F}
do-install:
${MKDIR} ${STAGEDIR}${FONTSDIR}
- cd ${WRKSRC} && \
- ${INSTALL_DATA} ${INSTDAT} *.ttf ${STAGEDIR}${FONTSDIR}
+ cd ${WRKSRC}/${PORTNAME}-${PORTVERSION} && \
+ ${INSTALL_DATA} *.ttf ${STAGEDIR}${FONTSDIR}
.include <bsd.port.mk>