aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/linuxlibertine-g/Makefile53
-rw-r--r--x11-fonts/linuxlibertine-g/distinfo2
-rw-r--r--x11-fonts/linuxlibertine-g/files/pkg-message.in5
-rw-r--r--x11-fonts/linuxlibertine-g/pkg-descr9
-rw-r--r--x11-fonts/linuxlibertine-g/pkg-plist15
6 files changed, 85 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 2f24ff37e8ea..f2890d5374ac 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -107,6 +107,7 @@
SUBDIR += linux-f10-fontconfig
SUBDIR += linux-fontconfig
SUBDIR += linuxlibertine
+ SUBDIR += linuxlibertine-g
SUBDIR += manu-gothica
SUBDIR += mgopen
SUBDIR += mkbold
diff --git a/x11-fonts/linuxlibertine-g/Makefile b/x11-fonts/linuxlibertine-g/Makefile
new file mode 100644
index 000000000000..b31772dab0fd
--- /dev/null
+++ b/x11-fonts/linuxlibertine-g/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: linuxlibertine-G
+# Date created: 24 April 2012
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= linuxlibertine-g
+PORTVERSION= 20120116
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.numbertext.org/linux/
+DISTNAME= e7a384790b13c29113e22e596ade9687-LinLibertineG-${PORTVERSION}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Linux Libertine G and Linux Biolinum G fonts
+
+BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_ZIP= yes
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+
+FONTNAME= LinLibertineG
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= fonts.dir fonts.scale
+
+WRKSRC= ${WRKDIR}/${FONTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${MKFONTSCL_CMD}
+ cd ${WRKSRC} && ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} ${WRKSRC}/*.ttf ${FONTDIR}
+
+post-install:
+ ${ECHO_MSG} "===> Running fc-cache"
+ -${LOCALBASE}/bin/fc-cache -f -v ${FONTDIR}
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/linuxlibertine-g/distinfo b/x11-fonts/linuxlibertine-g/distinfo
new file mode 100644
index 000000000000..38e1efab0e25
--- /dev/null
+++ b/x11-fonts/linuxlibertine-g/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip) = 54adcb2bc8cac0927a647fbd9362f45eff48130ce6e2379dc3867643019e08c5
+SIZE (e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip) = 6651982
diff --git a/x11-fonts/linuxlibertine-g/files/pkg-message.in b/x11-fonts/linuxlibertine-g/files/pkg-message.in
new file mode 100644
index 000000000000..dca252c8f1d3
--- /dev/null
+++ b/x11-fonts/linuxlibertine-g/files/pkg-message.in
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/linuxlibertine-g/pkg-descr b/x11-fonts/linuxlibertine-g/pkg-descr
new file mode 100644
index 000000000000..eeb7ca32fea7
--- /dev/null
+++ b/x11-fonts/linuxlibertine-g/pkg-descr
@@ -0,0 +1,9 @@
+Sample image of Linux Libertine. Source: Wikipedia Graphite versions of Linux
+Libertine and Linux Biolinum font families for LibreOffice and OpenOffice.org.
+Fonts with ligatures, true small caps, old style numbers, proportional or
+monospaced numbers, capital spacing, automatic thousand separation, true
+superscript and subscript, diagonal and nut fractions, different numbering
+styles: number to number name conversion (in more than 20 languages), footnote
+numbering styles; right aligned footnote numbers, etc
+
+WWW: http://numbertext.org/linux/
diff --git a/x11-fonts/linuxlibertine-g/pkg-plist b/x11-fonts/linuxlibertine-g/pkg-plist
new file mode 100644
index 000000000000..7f1b7644b810
--- /dev/null
+++ b/x11-fonts/linuxlibertine-g/pkg-plist
@@ -0,0 +1,15 @@
+%%FONTDIR%%/LinBiolinum_RB_G.ttf
+%%FONTDIR%%/LinLibertine_DR_G.ttf
+%%FONTDIR%%/LinLibertine_RI_G.ttf
+%%FONTDIR%%/LinLibertine_R_G.ttf
+%%FONTDIR%%/LinBiolinum_RI_G.ttf
+%%FONTDIR%%/LinLibertine_RBI_G.ttf
+%%FONTDIR%%/LinLibertine_RZI_G.ttf
+%%FONTDIR%%/LinBiolinum_R_G.ttf
+%%FONTDIR%%/LinLibertine_RB_G.ttf
+%%FONTDIR%%/LinLibertine_RZ_G.ttf
+%%FONTDIR%%/fonts.scale
+%%FONTDIR%%/fonts.dir
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%
+@exec %%LOCALBASE%%/bin/fc-cache -f -v %D/%%FONTDIR%% || /usr/bin/true