aboutsummaryrefslogtreecommitdiffstats
path: root/x11-servers/xephyr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-servers/xephyr/Makefile')
-rw-r--r--x11-servers/xephyr/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/x11-servers/xephyr/Makefile b/x11-servers/xephyr/Makefile
index 6a3feab859cf..e9d84e5de57c 100644
--- a/x11-servers/xephyr/Makefile
+++ b/x11-servers/xephyr/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xephyr
-PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTVERSION= 1.6.0
+#PORTREVISION= 1
CATEGORIES= x11-servers
MAINTAINER= x11@FreeBSD.org
@@ -23,11 +23,12 @@ USE_XORG= x11 xf86driproto glproto randrproto renderproto fixesproto \
xf86bigfontproto scrnsaverproto bigreqsproto \
resourceproto fontsproto videoproto \
compositeproto trapproto recordproto \
- xineramaproto evieproto xkbfile xfont \
+ xineramaproto xinerama evieproto xkbfile xfont \
xau xdmcp xext fontenc xv pixman
+USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-kdrive --enable-xephyr --disable-dmx --disable-xvfb \
- --disable-xorg --disable-xnest --disable-xprint \
+ --disable-xorg --disable-xnest \
--localstatedir=/var --without-dtrace
PLIST_FILES= bin/Xephyr
@@ -36,6 +37,13 @@ OPTIONS= HAL "Compile with HAL config support" on
.include <bsd.port.pre.mk>
+.if defined(WITH_OPENSSL_BASE)
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
+.endif
+
.if !defined(WITHOUT_HAL)
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --enable-config-hal=yes