aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/gtk-engines2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines2/Makefile')
-rw-r--r--x11-themes/gtk-engines2/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/x11-themes/gtk-engines2/Makefile b/x11-themes/gtk-engines2/Makefile
index d9fab95a93fe..4ad0fb659465 100644
--- a/x11-themes/gtk-engines2/Makefile
+++ b/x11-themes/gtk-engines2/Makefile
@@ -3,14 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/x11-themes/gtk-engines2/Makefile,v 1.1 2006/03/13 22:39:57 mezz Exp $
+# $MCom: ports/x11-themes/gtk-engines2/Makefile,v 1.29 2006/10/03 01:32:23 ahze Exp $
#
PORTNAME= gtk-engines2
-PORTVERSION= 2.6.10
+PORTVERSION= 2.8.1
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,21 +20,20 @@ COMMENT= Theme engine for the gtk+-2.0 toolkit
CONFLICTS= gtk-smooth-engine-[0-9]* clearlooks-[0-9]*
USE_BZIP2= yes
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gtk20
.if defined(WITH_ANIMATION)
-CFLAGS+= -DHAVE_ANIMATION=1
+CONFIGURE_ARGS+= --enable-animation
.endif
-pre-everything::
-.if !defined(WITH_ANIMATION)
- @${ECHO_MSG} ""
- @${ECHO_MSG} " You can enable experimental animated progressbars"
- @${ECHO_MSG} " with the clearlooks engine by defining"
- @${ECHO_MSG} " WITH_ANIMATION"
- @${ECHO_MSG} ""
+pre-everything::
+.if !defined(WITH_ANIMATION)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " You can enable experimental animated progressbars"
+ @${ECHO_MSG} " with the clearlooks engine by defining"
+ @${ECHO_MSG} " WITH_ANIMATION"
+ @${ECHO_MSG} ""
.endif
# Disable the gtk1 theme.