aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/gtk-qt4-engine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-qt4-engine/Makefile')
-rw-r--r--x11-themes/gtk-qt4-engine/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11-themes/gtk-qt4-engine/Makefile b/x11-themes/gtk-qt4-engine/Makefile
index a4aba9504295..e0d3eb114b0b 100644
--- a/x11-themes/gtk-qt4-engine/Makefile
+++ b/x11-themes/gtk-qt4-engine/Makefile
@@ -18,20 +18,15 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= BONOBO
BONOBO_DESC= Better support for Bonobo (GNOME) framework
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MBONOBO}
-USE_GNOME+= libbonoboui
-.endif
+BONOBO_USE= GNOME=libbonoboui
post-patch:
-.if !${PORT_OPTIONS:MBONOBO}
- @${REINPLACE_CMD} -e '/^PKGCONFIG(libbonoboui/d' \
- ${WRKSRC}/CMakeLists.txt
-.endif
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/kcm_gtk/searchpaths.cpp \
${WRKSRC}/src/rcproperties.cpp
+post-patch-BONOBO-off:
+ ${REINPLACE_CMD} -e '/^PKGCONFIG(libbonoboui/d' \
+ ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>