aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/sddm-freebsd-black-theme/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/sddm-freebsd-black-theme/Makefile')
-rw-r--r--x11-themes/sddm-freebsd-black-theme/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/sddm-freebsd-black-theme/Makefile b/x11-themes/sddm-freebsd-black-theme/Makefile
new file mode 100644
index 000000000000..77631b996702
--- /dev/null
+++ b/x11-themes/sddm-freebsd-black-theme/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= sddm-freebsd-black-theme
+PORTVERSION= 1.0
+CATEGORIES= x11-themes
+
+MAINTAINER= lbdm@privacychain.ch
+COMMENT= Simple SDDM theme inspired on the FBSD SLiM theme
+
+LICENSE= CC-BY-SA-3.0
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= lebarondemerde
+
+NO_BUILD= yes
+
+THEMEDIR_REL= share/sddm/themes/sddm-freebsd-black-theme
+THEMEDIR= ${PREFIX}/${THEMEDIR_REL}
+PLIST_SUB= THEMEDIR=${THEMEDIR_REL}
+
+SUB_FILES= pkg-message
+PORTDOCS= README.md AUTHORS COPYING TRADEMARKS
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${THEMEDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${THEMEDIR} \
+ "! ( -name README.md -o -name AUTHORS -o -name COPYING -o -name TRADEMARKS )")
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKDIR}/${PORTNAME}-${PORTVERSION} && \
+ ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>