aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes/xenostep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/xenostep/Makefile')
-rw-r--r--x11-themes/xenostep/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/xenostep/Makefile b/x11-themes/xenostep/Makefile
new file mode 100644
index 000000000000..315a3e5d49d6
--- /dev/null
+++ b/x11-themes/xenostep/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xenostep
+# Date Created: 14 November 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xenostep
+PORTVERSION= 200010300859
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_THEMES}
+MASTER_SITE_SUBDIR= gtk
+DISTNAME= XenoStep-1.2.x-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/XenoStep
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+ALL_TARGET= # empty
+MAKE_ENV= MKDIR="${MKDIR}"
+
+DIRS= "XenoStep Classic" "XenoStep Classic Small" "XenoStep HeliX" \
+ "XenoStep HeliX Small" "XenoStep Modern" "XenoStep Modern Small"
+
+post-extract:
+ for dir in ${DIRS}; do \
+ destdir=`${ECHO} $${dir} | ${SED} 's| |_|g'`; \
+ ${CP} -R "${WRKSRC}/$${dir}" "${WRKSRC}/$${destdir}"; \
+ done
+
+.include <bsd.port.mk>
an> * security/py-crits must use django v1.6 and will not work with v1.8dvl2015-06-301-2/+3 * Update to 3.4.0.wxs2015-06-302-3/+3 * Update to 3.4.0.wxs2015-06-304-18/+5 * After r390893, chmod u+w/u-w for stripping perl XS modules is unnecessary,adamw2015-06-293-6/+0 * security/vault: add missing line to rc scriptswills2015-06-292-0/+3 * - Add NO_ARCHsunpoet2015-06-291-0/+1 * - Update to 1.70sunpoet2015-06-282-3/+3 * - Mark ONLY_FOR_ARCHS: uses x86 assemblyamdmi32015-06-271-6/+5 * - Make xsel run dependency optional - it makes clipboard pastingpawel2015-06-271-2/+11 * Document qemu pcnet guest to host escape vulnerability - CVE-2015-3209nox2015-06-271-0/+36 * security/clambc is not jobs safe.marino2015-06-271-0/+2 * security/vault: create portswills2015-06-276-0/+227 * Document CVE-2014-3120, CVE-2014-6439, CVE-2015-1427, CVE-2015-3337,delphij2015-06-261-0/+210 * - Mark BROKEN on 9.x:amdmi32015-06-261-0/+2 * security/afl: Update to 1.83bdelphij2015-06-262-4/+4 * - Mark BROKEN on 9.x:amdmi32015-06-251-0/+2 * - Mark BROKEN on 9.x:amdmi32015-06-251-0/+2 * security/py-libnacl: Update to 1.4.3koobs2015-06-253-4/+17 * Split CVE-2015-4152 to its own entry as the affected port is logstash only.delphij2015-06-251-11/+75 * Add entry for logstash-forwarder/logstash.delphij2015-06-251-0/+53 * Support changed ETCDIR in pkg-plistbdrewery2015-06-252-7/+5 * Aggressively mark more consumers of bundled dcraw as vulnerablejbeich2015-06-251-2/+47 * Allow user overriding ETCDIRbdrewery2015-06-251-1/+2 * Update to 20150624 snapshotbdrewery2015-06-252-3/+3 * - Update to 1.4.11sunpoet2015-06-252-5/+10 * - Update to 1.80bamdmi32015-06-253-522/+16 * Convert all p5-Test-use-ok dependencies to p5-Test-Simple, but only onadamw2015-06-251-3/+8 * Document linux-*-flashplugin11 CVE.xmj2015-06-241-0/+41 * - Add LICENSEsunpoet2015-06-241-0/+2 * Remove expired portrm2015-06-244-26/+0 * - Add NO_ARCHsunpoet2015-06-231-0/+1 * - Update to 1.2.1sunpoet2015-06-232-3/+4 * Fix entry date.delphij2015-06-231-1/+1 * Document rubygem-bson DoS and possible injection vulnerability.delphij2015-06-231-0/+30 * Document 3 vulnerabilities with PHP that affected 4 extensions.delphij2015-06-231-0/+60 * Reflect version range change after r390340. While I'm there, also fixdelphij2015-06-231-2/+5 * Document vulnerabilities in devel/ipython < 3.2.0.olgeni2015-06-231-0/+36 * Remove deprecated USE_RCORDER which was already off except if one enforcedbapt2015-06-231-4/+0 * security/py-backports.ssl_match_hostname: add comment on blocker PRrm2015-06-231-0/+1 * Document new vulnerabilities in www/chromium < 43.0.2357.130rene2015-06-231-0/+49 * Document rubygem-paperclip validation bypass vulnerabilitiy.delphij2015-06-221-0/+36 * Document lang/chicken vulnerabilities CVE-2014-9651 and CVE-2015-4556.delphij2015-06-221-0/+64 * Document cacti multiple vulnerabilities (affects < 0.8.8c) anddelphij2015-06-221-0/+86 * Convert to USES=autoreconfbapt2015-06-221-6/+1 * - Update to 0.18sunpoet2015-06-212-3/+4 * Add p5-Dancer vuln.kuriyama2015-06-201-0/+30 * Fix fetchamdmi32015-06-191-2/+2 * remove target 'regression-test', it's on perl5.mk already.vanilla2015-06-191-3/+0 * Fix: pkg-static: POST-INSTALL script failedcy2015-06-191-30/+31 * Document Drupal multiple vulnerabilities.delphij2015-06-191-0/+76 * - Strip binariesamdmi32015-06-191-0/+5 * - Fix library installationamdmi32015-06-191-2/+2 * Chase py-ldap2 rename in more ports that I missed.rm2015-06-191-1/+1 * Fix build on non-root user.vanilla2015-06-181-0/+2 * 1: bump version for add depends to p5-JSON.vanilla2015-06-181-0/+10 * Upgrade to 0.023.vanilla2015-06-182-3/+3 * Document two vulnerabilities of cURL.delphij2015-06-181-0/+71 * - Make it compatible with Python 3.xsunpoet2015-06-181-1/+1 * - Document Ruby on Rails multiple vulnerabilitiessunpoet2015-06-181-0/+67 * Mark BROKEN: Depends on conflicting versions of djangoantoine2015-06-181-0/+2 * Modify a5f160fa-deee-11e4-99f8-080027ef73ec so it covers ja-mailman too.delphij2015-06-181-0/+5 * A Python library for parsing PGP packetsdelphij2015-06-174-0/+25 * Document testdisk multiple vulnerabilities.delphij2015-06-171-0/+40 * Update to 0.15.1.delphij2015-06-172-3/+3 * - Update to 5.19zi2015-06-162-4/+5 * - Add missing perl run-dependencyamdmi32015-06-162-3/+5 * - Simplify docs and plist handlingamdmi32015-06-161-12/+6 * Update to 201523.delphij2015-06-162-4/+3 * Document Tomcat multiple vulnerabilities.delphij2015-06-161-0/+49 * - Update to 1.2.0sunpoet2015-06-162-4/+3 * Update to 2.6.0 release.ale2015-06-153-8/+6 * Update PHP ports:ale2015-06-152-2/+0 * Update to 1.5.5jhale2015-06-153-5/+5 * Bump PORTREVISION because of svn commit r389649cs2015-06-151-0/+1 * fix broken pkg-plistcs2015-06-151-4/+0 * - update to upstream svn r269ohauer2015-06-155-69/+209 * security/libressl: Update to 2.2.0brnrd2015-06-144-10/+128 * Add py-gpsoauth, a Python client library for Google Play Services OAuthriggs2015-06-144-0/+39 * - Upgrade to 0.36.kuriyama2015-06-142-4/+7 * - Upgrade to 2.0.28 (bugfixes).kuriyama2015-06-142-5/+5 * - Add NO_ARCHsunpoet2015-06-141-0/+1 * - Update RUN_DEPENDS: use newer rubygem-racksunpoet2015-06-141-1/+3 * - Update RUN_DEPENDS: use newer rubygem-racksunpoet2015-06-141-1/+2 * - Updated libsodium to 1.0.3 [1]vsevolod2015-06-146-5/+9 * - Update WWWsunpoet2015-06-131-1/+1 * Sort entries.olgeni2015-06-131-1/+1 * - Upgrade to 2.1.5 (bugfixes, minor enhancements).kuriyama2015-06-132-6/+6 * - Update to 0.9.6tota2015-06-132-5/+4 * - Update to 0.6.8tota2015-06-133-17/+17 * - update to 1.0.2cdinoex2015-06-132-12/+12 * - Update security/polarssl13 to 1.3.11tijl2015-06-139-110/+92 * - use portable cpu option for sparcv8dinoex2015-06-121-5/+6 * - fix path in SIZE linesdinoex2015-06-121-3/+3 * - Correct patch filename for SIZEzi2015-06-121-1/+1 * Update security/ossec-hids-* to 2.8.2.brd2015-06-126-52/+58 * Add ossec-hids-* vulnerabilities.brd2015-06-121-0/+32 * - Restore missing checksum for 1001-crypto-hmac-support-EVP_MD_CTX_FLAG_ONESH...zi2015-06-121-1/+2 * Update to 0.2.6.9bf2015-06-122-3/+3 * - Update to 2.1.7 that fixes the recent openssl vulnerabilitiesvsevolod2015-06-124-15/+4 * - Add vulnerability information for additional ports affected by openssl CVEs...zi2015-06-121-0/+13 * - Resolve build issuezi2015-06-122-7/+7 * - Update to 1.0.2bzi2015-06-123-22/+21 * - Document recent vulnerabilities in security/opensslzi2015-06-121-0/+42 * Document 13 Flash vulnerabilities.xmj2015-06-111-0/+85 * security/sguil: Fix wrong dependency for databases/mysqltcl [1]bofh2015-06-1116-76/+59 * - Add LICENSEamdmi32015-06-111-2/+7 * Horde package update:mm2015-06-114-6/+6 * Update to new upstream release 2.3.7.mandree2015-06-116-350/+4 * security/rubygem-ezcrypto: update gemspec patch to new ruby-gems versionmmoll2015-06-111-1/+1 * Document libzmq4 V3 protocol handler protocol downgrade vulnerability.delphij2015-06-111-0/+31 * Document pgbouncer remote denial of service vulnerability.delphij2015-06-111-0/+29 * - Add NO_ARCHamdmi32015-06-112-2/+1 * - Add LICENSEamdmi32015-06-112-7/+5 * - Fix library installationamdmi32015-06-112-8/+3 * - Update to 0.06sunpoet2015-06-113-7/+11 * - Add NO_ARCHsunpoet2015-06-111-1/+2 * Update to 3.10.2lx2015-06-103-50/+67 * Document cups multiple vulnerabilities.delphij2015-06-101-0/+34 * Update to 1.4.1cs2015-06-103-4/+14 * - Update to 15.2.1sunpoet2015-06-102-3/+3 * Update to 5.3.2garga2015-06-094-4/+23 * Document two strongswan vulnerabilities.delphij2015-06-091-0/+59 * - add freebsd-mips targetdinoex2015-06-091-7/+13 * Document redis EVAL Lua sandbox escape vulnerability.delphij2015-06-091-0/+37 * Update to 20150608 snapshotbdrewery2015-06-092-3/+3 * security/fcrackzip: Take MAINTAINERSHIPbofh2015-06-094-8/+10 * Add an entry for www/tidy-* heap-buffer-overflow.thierry2015-06-091-0/+40 * Fix typo and remove PHP from pcre vulnerabilities, as the bundled pcredelphij2015-06-081-25/+2 * Document fixed version of pcre in e69af246-0ae2-11e5-90e4-d050996490d0.delphij2015-06-081-2/+2 * - Fix shebangsamdmi32015-06-071-1/+3 * MIT KRB5 ports build unusable binaries due to incorrect linkingcy2015-06-074-6/+10 * - Update VuXMLsunpoet2015-06-071-2/+6 * - Update to 2.0.2sunpoet2015-06-072-3/+3 * Update ocaml-ssl to 0.5.1johans2015-06-062-3/+3 * security/ca_root_nss: Enable certificate verification (for Base OpenSSL)koobs2015-06-061-0/+3 * - Re-add PHP removed in previous commitzi2015-06-061-1/+13 * - Fix shebangsamdmi32015-06-061-2/+3 * - Update to 1.69sunpoet2015-06-062-3/+5 * - Update to 2.0.1sunpoet2015-06-062-3/+3 * - Make version matching on the pcre vuln a little more sanezi2015-06-051-13/+2 * Document two recent pcre vulnerabilities that can be triggered bydelphij2015-06-051-0/+49 * Fix spellgarga2015-06-051-1/+1 * security/p5-Crypt-OpenSSL-X509: 1.8.04 -> 1.8.06pi2015-06-04