aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/slim-themes/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/x11-themes/slim-themes/Makefile b/x11-themes/slim-themes/Makefile
index 0f3e6537a362..7be55a859ea1 100644
--- a/x11-themes/slim-themes/Makefile
+++ b/x11-themes/slim-themes/Makefile
@@ -74,7 +74,6 @@ NEWTHEMES:= ${ALLTHEMES} ${n}
ALLTHEMES:= ${NEWTHEMES}
.endfor # t in ${THEMELIST}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.for n in ${ALLTHEMES}
@@ -106,12 +105,12 @@ post-patch:
# Install selected themes. Another regexp voodoo, yay! \o/
do-install:
- ${MKDIR} ${THEMEDIR}
+ ${MKDIR} ${STAGEDIR}${THEMEDIR}
.for n in ${ALLTHEMES}
.if ${PORT_OPTIONS:M${n}}
- ${MKDIR} ${THEMEDIR}/${${n}_DDIR}
+ ${MKDIR} ${STAGEDIR}${THEMEDIR}/${${n}_DDIR}
cd "${WRKSRC}/${${n}_SDIR}" && \
- ${COPYTREE_SHARE} . ${THEMEDIR}/${${n}_DDIR}
+ ${COPYTREE_SHARE} . ${STAGEDIR}${THEMEDIR}/${${n}_DDIR}
.endif # ${PORT_OPTIONS:M${n}}
.endfor # t in ${THEMELIST}