aboutsummaryrefslogtreecommitdiffstats
path: root/x11-themes
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-qt4-engine/Makefile35
-rw-r--r--x11-themes/gtk-qt4-engine/files/patch-src__qt_theme_draw.c10
-rw-r--r--x11-themes/gtk-qt4-engine/pkg-descr9
-rw-r--r--x11-themes/gtk-qt4-engine/pkg-plist5
4 files changed, 31 insertions, 28 deletions
diff --git a/x11-themes/gtk-qt4-engine/Makefile b/x11-themes/gtk-qt4-engine/Makefile
index 1449d732c37e..6fe3d72b2a2e 100644
--- a/x11-themes/gtk-qt4-engine/Makefile
+++ b/x11-themes/gtk-qt4-engine/Makefile
@@ -1,19 +1,14 @@
-# New ports collection makefile for: gtk-qt4-engine
-# Date created: 07 July 2008
-# Whom: Kris Moore <kris@pcbsd.org>
-#
+# Created by: Kris Moore <kris@pcbsd.org>
# $FreeBSD$
-#
-PORTNAME= gtk-qt4-engine
+PORTNAME= gtk-qt-engine
PORTVERSION= 1.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11-themes
-MASTER_SITES= http://gtk-qt-engine.googlecode.com/files/
-DISTFILES= gtk-qt-engine-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= makc@FreeBSD.org
-COMMENT= GTK-QT Theme Engine allows GTK2 apps to use QT/KDE themes
+COMMENT= GTK+ 2.x theme engine allowing to use Qt/KDE styles
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -21,21 +16,25 @@ USE_GNOME= gtk20
USE_QT4= moc_build rcc_build uic_build qmake_build
USE_CMAKE= yes
USE_KDE4= kdelibs kdeprefix automoc4
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
-OPTIONS= LIBBONOBOUI "Install libbonoboui if missing" off
+OPTIONS_DEFINE= BONOBO
+BONOBO_DESC= Better support for Bonobo (GNOME) framework
-WRKSRC= ${WRKDIR}/gtk-qt-engine
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LIBBONOBOUI)
+.if ${PORT_OPTIONS:MBONOBO}
USE_GNOME+= libbonoboui
.endif
post-patch:
+.if !${PORT_OPTIONS:MBONOBO}
+ @${REINPLACE_CMD} -e '/^PKGCONFIG(libbonoboui/d' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
- ${WRKSRC}/kcm_gtk/searchpaths.cpp
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/kcm_gtk/searchpaths.cpp \
${WRKSRC}/src/rcproperties.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-themes/gtk-qt4-engine/files/patch-src__qt_theme_draw.c b/x11-themes/gtk-qt4-engine/files/patch-src__qt_theme_draw.c
new file mode 100644
index 000000000000..9458d4f4e7cc
--- /dev/null
+++ b/x11-themes/gtk-qt4-engine/files/patch-src__qt_theme_draw.c
@@ -0,0 +1,10 @@
+--- ./src/qt_theme_draw.c.orig 2008-03-11 01:30:19.000000000 +0000
++++ ./src/qt_theme_draw.c 2012-10-06 10:09:43.994767020 +0000
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include <math.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <gtk/gtkprogressbar.h>
+ #include <gdk/gdk.h>
diff --git a/x11-themes/gtk-qt4-engine/pkg-descr b/x11-themes/gtk-qt4-engine/pkg-descr
index 398c6d3572d4..fd5803c528fe 100644
--- a/x11-themes/gtk-qt4-engine/pkg-descr
+++ b/x11-themes/gtk-qt4-engine/pkg-descr
@@ -1,6 +1,5 @@
-GTK-QT4 Theme Engine allows GTK2 apps to use QT/KDE themes
-so that they fit in more nicely with KDE. Includes a KDE4
-system settings module for GTK theme selection.
+GTK-Qt theme engine allows GTK+ 2.x applications to use Qt4 styles
+so that they fit in more nicely with KDE desktop. The port also
+provides KDE 4 system settings module for GTK+ theme selection.
-Author: David Sansome <me@davidsansome.com>
-WWW: http://gtk-qt.ecs.soton.ac.uk/index.php
+WWW: http://code.google.com/p/gtk-qt-engine/
diff --git a/x11-themes/gtk-qt4-engine/pkg-plist b/x11-themes/gtk-qt4-engine/pkg-plist
index 1a46e39cb498..ba4c4241d379 100644
--- a/x11-themes/gtk-qt4-engine/pkg-plist
+++ b/x11-themes/gtk-qt4-engine/pkg-plist
@@ -11,13 +11,8 @@ share/locale/nn/LC_MESSAGES/gtkqtengine.mo
share/locale/ru/LC_MESSAGES/gtkqtengine.mo
share/locale/sv/LC_MESSAGES/gtkqtengine.mo
share/locale/tr/LC_MESSAGES/gtkqtengine.mo
-@dirrmtry share/applications/kde4
-@dirrmtry lib/kde4
@cwd %%LOCALBASE%%
lib/gtk-2.0/%%GTK2_VERSION%%/engines/libqt4engine.so
share/themes/Qt4/gtk-2.0/gtkrc
@dirrm share/themes/Qt4/gtk-2.0
@dirrm share/themes/Qt4
-@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%/engines
-@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%
-@dirrmtry lib/gtk-2.0