aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index e7b73b4229e9..eb0b928836f7 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fltk
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/${PORTVERSION}
@@ -16,28 +16,29 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
USE_LDCONFIG= yes
USE_XORG= xft
-USE_GL= gl glu
-USE_GCC= any
+USE_GL= glu
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-threads \
--enable-shared \
--enable-xft
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${WRKSRC}/src -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
MAN1= fltk-config.1 fluid.1
MAN3= fltk.3
post-patch:
- ${REINPLACE_CMD} -e '30s/test //' ${WRKSRC}/Makefile
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
${WRKSRC}/src/Fl_Preferences.cxx
.if !defined(NOPORTDOCS)
-PORTDOCS= *
post-install:
cd ${WRKSRC}/documentation && ${MAKE} docinstall
cd ${WRKSRC}/test && ${MAKE} install