aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/flu
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/flu')
-rw-r--r--x11-toolkits/flu/Makefile45
-rw-r--r--x11-toolkits/flu/distinfo2
-rw-r--r--x11-toolkits/flu/files/patch-FLU_Flu_Tree_Browser.h73
-rw-r--r--x11-toolkits/flu/files/patch-FLU_Makefile16
-rw-r--r--x11-toolkits/flu/files/patch-configure22
-rw-r--r--x11-toolkits/flu/files/patch-src_Flu_File_Chooser.cpp11
-rw-r--r--x11-toolkits/flu/files/patch-src_Flu_Tree_Browser.cpp36
-rw-r--r--x11-toolkits/flu/files/patch-src_Makefile37
-rw-r--r--x11-toolkits/flu/pkg-descr3
-rw-r--r--x11-toolkits/flu/pkg-plist57
10 files changed, 0 insertions, 302 deletions
diff --git a/x11-toolkits/flu/Makefile b/x11-toolkits/flu/Makefile
deleted file mode 100644
index 9b9191597222..000000000000
--- a/x11-toolkits/flu/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: flu
-# Date created: 07 Apr 2006
-# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= flu
-PORTVERSION= 2.14
-PORTREVISION= 9
-CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.osc.edu/archive/FLU/
-DISTNAME= FLU_${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A library containing extra widgets for FLTK
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
-
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-
-USE_GL= gl
-USE_LDCONFIG= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --I=${LOCALBASE}/include --L=${LOCALBASE}/lib
-USE_GMAKE= yes
-PORTDOCS= *
-
-SHLIB_VERSION= 0
-PLIST_SUB= SHLIB_VERSION="${SHLIB_VERSION}"
-MAKE_ENV= SHLIB_VERSION="${SHLIB_VERSION}"
-
-post-patch:
- @${RM} -rf ${WRKSRC}/doc/CVS
-
-post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/x11-toolkits/flu/distinfo b/x11-toolkits/flu/distinfo
deleted file mode 100644
index c03734cbd1ff..000000000000
--- a/x11-toolkits/flu/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (FLU_2.14.tar.gz) = cbdf99637e28b2c749c9012c73a8cccd9977ce53eb896c2aab34f1b57d2d2060
-SIZE (FLU_2.14.tar.gz) = 632464
diff --git a/x11-toolkits/flu/files/patch-FLU_Flu_Tree_Browser.h b/x11-toolkits/flu/files/patch-FLU_Flu_Tree_Browser.h
deleted file mode 100644
index d3057665f557..000000000000
--- a/x11-toolkits/flu/files/patch-FLU_Flu_Tree_Browser.h
+++ /dev/null
@@ -1,73 +0,0 @@
---- FLU/Flu_Tree_Browser.h.orig 2004-11-05 18:03:20.000000000 +0100
-+++ FLU/Flu_Tree_Browser.h 2011-11-16 10:36:16.000000000 +0100
-@@ -218,10 +218,6 @@
- inline void color( Fl_Color c )
- { _box->color( c ); }
-
-- //! Set the background color of the browser. Default is FL_WHITE
-- inline void color( unsigned c )
-- { _box->color( (Fl_Color)c ); }
--
- //! Set the color, style, and width of the connector lines. Default is FL_DARK2, FL_DOT, 1
- inline void connector_style( Fl_Color color, int style, int width = 1 )
- { rdata.defLineColor = color; rdata.lineStyle = style; rdata.lineWidth = width; }
-@@ -346,7 +342,7 @@
- { return rdata.insertionMode; }
-
- //! \return whether the point \c (x,y) is inside the entry area (not on the scrollbars)
-- bool Flu_Tree_Browser :: inside_entry_area( int x, int y );
-+ bool inside_entry_area( int x, int y );
-
- //! Set the title of the Tree (also the label for the root entry)
- inline void label( const char *l )
-@@ -436,23 +432,23 @@
-
- //! Remove the entry identified by path \b fullpath from the tree
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
-- unsigned int remove( const char *fullpath );
-+ unsigned long remove( const char *fullpath );
-
- //! Remove entry \b name in path \b path from the tree
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
-- unsigned int remove( const char *path, const char *name );
-+ unsigned long remove( const char *path, const char *name );
-
- //! Remove the entry identified by unique id \b id from the tree
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
-- unsigned int remove( unsigned int id );
-+ unsigned long remove( unsigned int id );
-
- //! Remove the entry containing the widget \b w from the tree. Note that the widget is automatically destroyed
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
-- unsigned int remove( Fl_Widget *w );
-+ unsigned long remove( Fl_Widget *w );
-
- //! Remove Node \b n from the tree
- /*! \return the id of \b n on successful removal, or \c 0 if \b n is not in the tree */
-- inline unsigned int remove( Node* n )
-+ inline unsigned long remove( Node* n )
- { if( !n ) return 0; else return remove( n->id() ); }
-
- //! Override of Fl_Widget::resize
-@@ -494,10 +490,6 @@
- inline void selection_color( Fl_Color c )
- { rdata.defSelectionColor = c; }
-
-- //! Set the color to use when hilighting selected entries. Default is FL_SELECTION_COLOR
-- inline void selection_color( unsigned c )
-- { selection_color( (Fl_Color)c ); }
--
- //! Set how selection is affected when the mouse is dragged. This can be one of FLU_DRAG_IGNORE, FLU_DRAG_TO_SELECT, FLU_DRAG_TO_MOVE. Default is FLU_DRAG_TO_SELECT.
- inline void selection_drag_mode( int m )
- { rdata.selectionDragMode = m; }
-@@ -1077,8 +1069,8 @@
-
- //! Remove the entry identified by path \b fullpath from this node
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
-- inline unsigned int remove( const char *fullpath )
-- { return( (unsigned int)modify( fullpath, REMOVE, tree->rdata ) ); }
-+ inline unsigned long remove( const char *fullpath )
-+ { return( (unsigned long )modify( fullpath, REMOVE, tree->rdata ) ); }
-
- //! Remove the entry identified by unique id \b id from this node
- /*! \return the unique id of the removed entry, or \c 0 if no matching entry was found */
diff --git a/x11-toolkits/flu/files/patch-FLU_Makefile b/x11-toolkits/flu/files/patch-FLU_Makefile
deleted file mode 100644
index b0260b24d614..000000000000
--- a/x11-toolkits/flu/files/patch-FLU_Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- FLU/Makefile.orig Fri Apr 7 15:05:59 2006
-+++ FLU/Makefile Fri Apr 7 15:06:33 2006
-@@ -4,12 +4,8 @@
-
- install:
- @ echo "Installing include files in $(IPREFIX)..."
-- @ mkdir -p $(IPREFIX)
-- @ rm -rf $(IPREFIX)/FLU
- @ mkdir -p $(IPREFIX)/FLU
-- @ chmod 755 $(IPREFIX)/FLU
-- @ cp *.h $(IPREFIX)/FLU
-- @ chmod 644 $(IPREFIX)/FLU/*.h
-+ @ $(BSD_INSTALL_DATA) *.h $(IPREFIX)/FLU
-
- uninstall:
- @ echo "Uninstalling include files from $(IPREFIX)..."
diff --git a/x11-toolkits/flu/files/patch-configure b/x11-toolkits/flu/files/patch-configure
deleted file mode 100644
index 69dacf7bcedb..000000000000
--- a/x11-toolkits/flu/files/patch-configure
+++ /dev/null
@@ -1,22 +0,0 @@
---- configure.orig Tue Oct 26 17:09:51 2004
-+++ configure Fri Apr 7 15:17:23 2006
-@@ -387,8 +387,6 @@
- if test $ENABLE_DEBUG -eq 1
- then
- CXXFLAGS=$CXXFLAGS" -g"
--else
-- CXXFLAGS=$CXXFLAGS" -O2"
- fi
-
- if test $OSX -eq 1
-@@ -543,9 +541,7 @@
- @ echo "=== installing FLU ==="
- @ echo "Installing binaries in $(BPREFIX)..."
- @ mkdir -p $(BPREFIX)
-- @ rm -f $(BPREFIX)/flu-config
-- @ cp flu-config $(BPREFIX)
-- @ chmod 755 $(BPREFIX)/flu-config
-+ @ $(BSD_INSTALL_SCRIPT) flu-config $(BPREFIX)
- @for dir in FLU $(DIRS); do \
- (cd $$dir; $(MAKE) $(MFLAGS) install) || break;\
- done
diff --git a/x11-toolkits/flu/files/patch-src_Flu_File_Chooser.cpp b/x11-toolkits/flu/files/patch-src_Flu_File_Chooser.cpp
deleted file mode 100644
index 27f24070a9dd..000000000000
--- a/x11-toolkits/flu/files/patch-src_Flu_File_Chooser.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Flu_File_Chooser.cpp.orig 2010-01-15 11:52:23.000000000 +0100
-+++ src/Flu_File_Chooser.cpp 2010-01-15 11:52:55.000000000 +0100
-@@ -2773,7 +2773,7 @@
- const Fl_Menu_Item *selection = entryPopup.popup();
- if( selection )
- {
-- int handler = (int)selection->user_data();
-+ long handler = (long)selection->user_data();
- switch( handler )
- {
- case ACTION_NEW_FOLDER:
diff --git a/x11-toolkits/flu/files/patch-src_Flu_Tree_Browser.cpp b/x11-toolkits/flu/files/patch-src_Flu_Tree_Browser.cpp
deleted file mode 100644
index 1bbd5a10def0..000000000000
--- a/x11-toolkits/flu/files/patch-src_Flu_Tree_Browser.cpp
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/Flu_Tree_Browser.cpp.orig 2010-01-15 11:54:00.000000000 +0100
-+++ src/Flu_Tree_Browser.cpp 2010-01-15 11:57:06.000000000 +0100
-@@ -2981,12 +2981,12 @@
- return add( path, p.c_str(), w, showLabel );
- }
-
--unsigned int Flu_Tree_Browser :: remove( const char *fullpath )
-+unsigned long Flu_Tree_Browser :: remove( const char *fullpath )
- {
-- return( (unsigned int)root.modify( fullpath, Node::REMOVE, rdata ) );
-+ return( (unsigned long)root.modify( fullpath, Node::REMOVE, rdata ) );
- }
-
--unsigned int Flu_Tree_Browser :: remove( const char *path, const char *text )
-+unsigned long Flu_Tree_Browser :: remove( const char *path, const char *text )
- {
- // if the path does not end in '/', add it
- FluSimpleString s = path;
-@@ -2996,7 +2996,7 @@
- return remove( s.c_str() );
- }
-
--unsigned int Flu_Tree_Browser :: remove( unsigned int id )
-+unsigned long Flu_Tree_Browser :: remove( unsigned int id )
- {
- return root.remove( id );
- }
-@@ -3028,7 +3028,7 @@
- return 0;
- }
-
--unsigned int Flu_Tree_Browser :: remove( Fl_Widget *w )
-+unsigned long Flu_Tree_Browser :: remove( Fl_Widget *w )
- {
- return root.remove( w );
- }
diff --git a/x11-toolkits/flu/files/patch-src_Makefile b/x11-toolkits/flu/files/patch-src_Makefile
deleted file mode 100644
index cf59c46780ae..000000000000
--- a/x11-toolkits/flu/files/patch-src_Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/Makefile.orig Thu Sep 23 21:24:39 2004
-+++ src/Makefile Mon Apr 10 09:35:07 2006
-@@ -47,10 +47,10 @@
- STATIC_LIB_DIR = ../lib
-
- SHARED_LINK = libflu.$(SHARED_EXT)
--SHARED_LIB = $(SHARED_LINK).$(VERSION)
-+SHARED_LIB = $(SHARED_LINK).$(SHLIB_VERSION)
- STATIC_LIB = libflu.a
- GL_SHARED_LINK = libflu_gl.$(SHARED_EXT)
--GL_SHARED_LIB = $(GL_SHARED_LINK).$(VERSION)
-+GL_SHARED_LIB = $(GL_SHARED_LINK).$(SHLIB_VERSION)
- GL_STATIC_LIB = libflu_gl.a
-
- LIBS = $(STATIC_LIB)
-@@ -89,15 +89,15 @@
- install: $(LIBS)
- @ echo "Installing libraries in $(LPREFIX)..."
- @ mkdir -p $(LPREFIX)
-- @ rm -f $(LPREFIX)/$(STATIC_LIB) $(LPREFIX)/$(GL_STATIC_LIB) $(LPREFIX)/$(SHARED_LINK) $(LPREFIX)/$(GL_SHARED_LINK) $(LPREFIX)/$(SHARED_LIB) $(LPREFIX)/$(GL_SHARED_LIB)
- @ for file in $(LIBS); do \
-- cp $$file $(LPREFIX)/; \
-- chmod 755 $(LPREFIX)/$$file; \
-- if test $$file = $(SHARED_LIB); then \
-+ if [ $$file = $(SHARED_LIB) ]; then \
-+ $(BSD_INSTALL_PROGRAM) $$file $(LPREFIX); \
- ln -sf $(SHARED_LIB) $(LPREFIX)/$(SHARED_LINK); \
-- fi ; \
-- if test $$file = $(GL_SHARED_LIB); then \
-+ elif [ $$file = $(GL_SHARED_LIB) ]; then \
-+ $(BSD_INSTALL_PROGRAM) $$file $(LPREFIX); \
- ln -sf $(GL_SHARED_LIB) $(LPREFIX)/$(GL_SHARED_LINK); \
-+ else \
-+ $(BSD_INSTALL_DATA) $$file $(LPREFIX); \
- fi; \
- done
-
diff --git a/x11-toolkits/flu/pkg-descr b/x11-toolkits/flu/pkg-descr
deleted file mode 100644
index c9a974ce32ec..000000000000
--- a/x11-toolkits/flu/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-FLU is a library containing extra widgets for the FLTK windowing toolkit.
-
-WWW: http://www.osc.edu/archive/FLU/
diff --git a/x11-toolkits/flu/pkg-plist b/x11-toolkits/flu/pkg-plist
deleted file mode 100644
index 693202ff889a..000000000000
--- a/x11-toolkits/flu/pkg-plist
+++ /dev/null
@@ -1,57 +0,0 @@
-bin/flu-config
-include/FLU/FluSimpleString.h
-include/FLU/FluVectorClass.h
-include/FLU/Flu_Button.h
-include/FLU/Flu_Chat_Buffer.h
-include/FLU/Flu_Choice_Group.h
-include/FLU/Flu_Collapsable_Group.h
-include/FLU/Flu_Combo_Box.h
-include/FLU/Flu_Combo_List.h
-include/FLU/Flu_Combo_Tree.h
-include/FLU/Flu_DND.h
-include/FLU/Flu_Dual_Progress_Meter.h
-include/FLU/Flu_Dual_Slider.h
-include/FLU/Flu_Enumerations.h
-include/FLU/Flu_File_Chooser.h
-include/FLU/Flu_Float_Input.h
-include/FLU/Flu_GL_Canvas.h
-include/FLU/Flu_GL_Window.h
-include/FLU/Flu_Helpers.h
-include/FLU/Flu_Int_Input.h
-include/FLU/Flu_Label.h
-include/FLU/Flu_Link_Button.h
-include/FLU/Flu_Output.h
-include/FLU/Flu_Progress.h
-include/FLU/Flu_Progress_Meter.h
-include/FLU/Flu_Return_Button.h
-include/FLU/Flu_Separator.h
-include/FLU/Flu_Simple_Group.h
-include/FLU/Flu_Spinner.h
-include/FLU/Flu_Toggle_Group.h
-include/FLU/Flu_Tree_Browser.h
-include/FLU/Flu_Wrap_Group.h
-include/FLU/flu_export.h
-include/FLU/flu_file_chooser_pixmaps.h
-include/FLU/flu_pixmaps.h
-lib/libflu.a
-lib/libflu.so
-lib/libflu.so.%%SHLIB_VERSION%%
-lib/libflu_gl.a
-lib/libflu_gl.so
-lib/libflu_gl.so.%%SHLIB_VERSION%%
-%%EXAMPLESDIR%%/Flu_Button_Try.cpp
-%%EXAMPLESDIR%%/Flu_Chat_Buffer_Try.cpp
-%%EXAMPLESDIR%%/Flu_Combo_Box_Try.cpp
-%%EXAMPLESDIR%%/Flu_DND_Try.cpp
-%%EXAMPLESDIR%%/Flu_Dual_Slider_Try.cpp
-%%EXAMPLESDIR%%/Flu_File_Chooser_Try.cpp
-%%EXAMPLESDIR%%/Flu_Group_Try.cpp
-%%EXAMPLESDIR%%/Flu_Group_Try2.cpp
-%%EXAMPLESDIR%%/Flu_Progress_Try.cpp
-%%EXAMPLESDIR%%/Flu_Spinner_Try.cpp
-%%EXAMPLESDIR%%/Flu_Tree_Browser_Try.cpp
-%%EXAMPLESDIR%%/Flu_Tree_Browser_Try2.cpp
-%%EXAMPLESDIR%%/Flu_Wrap_Group_Try.cpp
-%%EXAMPLESDIR%%/undo_redo.cpp
-@dirrm include/FLU
-@dirrm %%EXAMPLESDIR%%