aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fox/Makefile')
-rw-r--r--x11-toolkits/fox/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index 98823ba47879..2d1e2b094991 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -6,16 +6,28 @@
#
PORTNAME= fox
-PORTVERSION= 0.99.135
+PORTVERSION= 0.99.157
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
ftp://SunSITE.Informatik.RWTH-Aachen.DE/pub/Linux/fox/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
+.if defined(WITH_XUNICODE)
+PKGNAMESUFFIX= -xunicode
+
+PATCH_SITES= http://www.ab.wakwak.com/~tino/jatk/fox/
+PATCHFILES= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}.diff
+PATCH_DIST_STRIP= -p1
+
+#EXTRA_PATCHES= ${PATCHDIR}/xunicode.patch-*
+
+BUILD_DEPENDS= ${X11BASE}/lib/libxunicode.a:${PORTSDIR}/converters/xunicode
+.endif
+
USE_MESA= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS+=--with-opengl=mesa --with-x