aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fox17/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fox17/Makefile')
-rw-r--r--x11-toolkits/fox17/Makefile36
1 files changed, 31 insertions, 5 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 1374c03be126..9171a6aa1e29 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fox
-PORTVERSION= 1.7.31
+PORTVERSION= 1.7.32
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/
@@ -14,13 +14,15 @@ MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
MAINTAINER= gahr@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit -- devel version
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFLICTS= fox-1.4.* fox-1.6.*
+OPTIONS= JPEG "Enable JPEG support" ON \
+ PNG "Enable PNG support" ON \
+ TIFF "Enable TIFF support" ON \
+ WEBP "Enable WebP support" ON
+
LATEST_LINK= fox17
MAJORVER= ${PORTVERSION:R}
@@ -42,6 +44,30 @@ MAN1= reswrap.1 shutterbug.1 adie.1 PathFinder.1 calculator.1 \
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+=--disable-jpeg
+.else
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+.endif
+
+.if defined(WITHOUT_PNG)
+CONFIGURE_ARGS+=--disable-png
+.else
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+.endif
+
+.if defined(WITHOUT_TIFF)
+CONFIGURE_ARGS+=--disable-tiff
+.else
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.endif
+
+.if defined(WITHOUT_WEBP)
+CONFIGURE_ARGS+=--disable-webp
+.else
+LIB_DEPENDS+= webp.2:${PORTSDIR}/graphics/webp
+.endif
+
.if ${ARCH} == "amd64" && ${OSVERSION} < 900000
BROKEN= does not build on amd64
.endif