aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/fxscintilla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/fxscintilla/Makefile')
-rw-r--r--x11-toolkits/fxscintilla/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-toolkits/fxscintilla/Makefile b/x11-toolkits/fxscintilla/Makefile
new file mode 100644
index 000000000000..477b30095047
--- /dev/null
+++ b/x11-toolkits/fxscintilla/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fxscintilla
+# Date created: 16 June 2004
+# Whom: Alexander Novitsky <alecn2002@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fxscintilla
+PORTVERSION= 1.57
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alecn2002@yandex.ru
+COMMENT= A Fox toolkit reimplementation of Scintilla editing widget
+
+LIB_DEPENDS= FOX-1.0.0:${PORTSDIR}/x11-toolkits/fox
+
+USE_LIBTOOL_VER= 15
+CONFIGURE_ARGS= --enable-shared
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>