aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk-sharp-beans/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk-sharp-beans/Makefile')
-rw-r--r--x11-toolkits/gtk-sharp-beans/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-toolkits/gtk-sharp-beans/Makefile b/x11-toolkits/gtk-sharp-beans/Makefile
new file mode 100644
index 000000000000..1707dca220ba
--- /dev/null
+++ b/x11-toolkits/gtk-sharp-beans/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gtk-sharp-beans
+PORTVERSION= 2.14.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Extensions on top of GTK-sharp
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gio-sharp-2.0.pc:${PORTSDIR}/devel/gio-sharp
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(libdir)data/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>