aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk13/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk13/Makefile')
-rw-r--r--x11-toolkits/gtk13/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/x11-toolkits/gtk13/Makefile b/x11-toolkits/gtk13/Makefile
index 47d3fc8e8399..0136c7202403 100644
--- a/x11-toolkits/gtk13/Makefile
+++ b/x11-toolkits/gtk13/Makefile
@@ -1,43 +1,49 @@
-# New ports collection makefile for: gtk11-devel
-# Version required: 1.1.16
+# New ports collection makefile for: gtk12
+# Version required: 1.2.0
# Date Created: 28 Sep 1997
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $Id: Makefile,v 1.44 1999/02/18 04:49:25 vanilla Exp $
#
-DISTNAME= gtk+-1.1.16
-PKGNAME= gtk-1.1.16
+DISTNAME= gtk+-1.2.0
+PKGNAME= gtk-1.2.0
CATEGORIES= x11-toolkits
-MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.1/ \
- ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.1/ \
- http://www.ameth.org/gimp/gtk/v1.1/
+MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.2/ \
+ ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.2/ \
+ http://www.ameth.org/gimp/gtk/v1.2/
MAINTAINER= vanilla@FreeBSD.ORG
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
RUN_DEPENDS= gettext:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= glib11d.2:${PORTSDIR}/devel/glib11-devel
+LIB_DEPENDS= glib12.1:${PORTSDIR}/devel/glib12
USE_X_PREFIX= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk11d
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk12
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib12-config" \
LIBS="-L${LOCALBASE}/lib"
-MAN1= gtk-config.1
+MAN1= gtk12-config.1
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
- @${MKDIR} ${LOCALBASE}/share/aclocal
- @${INSTALL_DATA} ${WRKSRC}/gtk.m4 ${LOCALBASE}/share/aclocal/gtk11d.m4
+ @${MKDIR} ${PREFIX}/share/themes/engines
@if [ ! -f ${PREFIX}/share/info ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ @${ECHO} '*********************************************************'
+ @${ECHO} '* *'
+ @${ECHO} '* If you want to use autoconf with gtk, *'
+ @${ECHO} '* Please copy gtk.m4 to /usr/local/share/aclocal *'
+ @${ECHO} '* by yourself, thanks. *'
+ @${ECHO} '* *'
+ @${ECHO} '*********************************************************'
.include <bsd.port.mk>
>+1 * emulators/yuzu: update to s20200911Jan Beich2020-09-121-1/+1 * devel/libfmt: Update to 7.0.3Tobias Kortkamp2020-09-081-1/+1 * emulators/yuzu: update to s20200829Jan Beich2020-08-301-1/+1 * emulators/{citra,yuzu}: update OSS patchesJan Beich2020-08-301-1/+1 * emulators/yuzu: update to s20200824Jan Beich2020-08-251-1/+1 * emulators/{citra,yuzu}: update OSS patchesJan Beich2020-08-241-1/+1 * emulators/yuzu: update to s20200820Jan Beich2020-08-221-1/+1 * emulators/{citra,yuzu}: replace ALSA with OSS (a la r545611)Jan Beich2020-08-221-1/+1 * emulators/yuzu: update to s20200731Jan Beich2020-08-011-1/+1 * devel/libfmt: Update to 7.0.2Tobias Kortkamp2020-08-011-1/+1 * emulators/yuzu: update to s20200719Jan Beich2020-07-211-1/+1 * devel/libfmt: Update to 7.0.1Tobias Kortkamp2020-07-211-1/+1 * emulators/yuzu: update to s20200413Jan Beich2020-04-141-1/+1 * emulators/yuzu: advertise Vulkan supportJan Beich2020-04-141-1/+1 * emulators/yuzu: update to s20191226Jan Beich2019-12-281-1/+1 * emulators/{citra,yuzu}: prefer SNDIO over ALSA after r520939Jan Beich2019-12-281-1/+1 * emulators/yuzu: update cubeb to pick up sndio fixesJan Beich2019-12-271-1/+1 * emulators/yuzu: update to s20191213Jan Beich2019-12-141-1/+1 * emulators/yuzu: switch FreeBSD 11.2/12.0 to bundled libc++Jan Beich2019-12-121-1/+1 * devel/boost-*: update to 1.72.0Jan Beich2019-12-121-1/+1 * emulators/yuzu: update to s20191007Jan Beich2019-10-081-1/+1 * emulators/yuzu: unbreak runtime after r513803Jan Beich2019-10-061-1/+1 * emulators/yuzu: update to s20190909Jan Beich2019-09-101-1/+1 * emulators/{citra,yuzu}: enable SNDIO by defaultJan Beich2019-09-081-1/+1 * emulators/yuzu: update to s20190818Jan Beich2019-08-201-1/+1 * devel/boost-*: update to 1.71.0Jan Beich2019-08-191-1/+1