aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile4
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c11
2 files changed, 14 insertions, 1 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 9acc0c1e6219..e14465dcd511 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.4,} \
ftp://ftp.gtk.org/pub/gtk/v2.3/ \
@@ -66,7 +67,8 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/gtk/xdgmime/xdgmime.c
pre-build:
diff --git a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
new file mode 100644
index 000000000000..14804bd2e143
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
@@ -0,0 +1,11 @@
+--- gtk/xdgmime/xdgmime.c.orig Wed Jun 23 20:19:43 2004
++++ gtk/xdgmime/xdgmime.c Wed Jun 23 20:19:56 2004
+@@ -98,7 +98,7 @@
+
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/:%%X11BASE%%/share/:/usr/share/";
+
+ ptr = xdg_data_dirs;
+