aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk20
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk20')
-rw-r--r--x11-toolkits/gtk20/Makefile32
-rw-r--r--x11-toolkits/gtk20/distinfo2
-rw-r--r--x11-toolkits/gtk20/files/patch-ad15
-rw-r--r--x11-toolkits/gtk20/files/patch-ae22
-rw-r--r--x11-toolkits/gtk20/pkg-descr7
-rw-r--r--x11-toolkits/gtk20/pkg-plist269
6 files changed, 183 insertions, 164 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 47d3fc8e8399..0136c7202403 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -1,43 +1,49 @@
-# New ports collection makefile for: gtk11-devel
-# Version required: 1.1.16
+# New ports collection makefile for: gtk12
+# Version required: 1.2.0
# Date Created: 28 Sep 1997
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
#
# $Id: Makefile,v 1.44 1999/02/18 04:49:25 vanilla Exp $
#
-DISTNAME= gtk+-1.1.16
-PKGNAME= gtk-1.1.16
+DISTNAME= gtk+-1.2.0
+PKGNAME= gtk-1.2.0
CATEGORIES= x11-toolkits
-MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.1/ \
- ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.1/ \
- http://www.ameth.org/gimp/gtk/v1.1/
+MASTER_SITES= ftp://ftp.gimp.org/pub/gtk/v1.2/ \
+ ftp://ftp.cs.umn.edu/pub/gimp/gtk/v1.2/ \
+ http://www.ameth.org/gimp/gtk/v1.2/
MAINTAINER= vanilla@FreeBSD.ORG
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
RUN_DEPENDS= gettext:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= glib11d.2:${PORTSDIR}/devel/glib11-devel
+LIB_DEPENDS= glib12.1:${PORTSDIR}/devel/glib12
USE_X_PREFIX= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk11d
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk12
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib12-config" \
LIBS="-L${LOCALBASE}/lib"
-MAN1= gtk-config.1
+MAN1= gtk12-config.1
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
- @${MKDIR} ${LOCALBASE}/share/aclocal
- @${INSTALL_DATA} ${WRKSRC}/gtk.m4 ${LOCALBASE}/share/aclocal/gtk11d.m4
+ @${MKDIR} ${PREFIX}/share/themes/engines
@if [ ! -f ${PREFIX}/share/info ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ @${ECHO} '*********************************************************'
+ @${ECHO} '* *'
+ @${ECHO} '* If you want to use autoconf with gtk, *'
+ @${ECHO} '* Please copy gtk.m4 to /usr/local/share/aclocal *'
+ @${ECHO} '* by yourself, thanks. *'
+ @${ECHO} '* *'
+ @${ECHO} '*********************************************************'
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk20/distinfo b/x11-toolkits/gtk20/distinfo
index 992dadfae7e1..b648580fc3d6 100644
--- a/x11-toolkits/gtk20/distinfo
+++ b/x11-toolkits/gtk20/distinfo
@@ -1 +1 @@
-MD5 (gtk+-1.1.16.tar.gz) = 6de7a1a397eac37d7fc1f8ef008a9f02
+MD5 (gtk+-1.2.0.tar.gz) = d935cf94a4b0167b6b3570580a1013b9
diff --git a/x11-toolkits/gtk20/files/patch-ad b/x11-toolkits/gtk20/files/patch-ad
index e0851a1a730f..43832268e1e3 100644
--- a/x11-toolkits/gtk20/files/patch-ad
+++ b/x11-toolkits/gtk20/files/patch-ad
@@ -1,6 +1,6 @@
--- gtk/gtkrc.c.orig Mon Jan 4 17:33:28 1999
+++ gtk/gtkrc.c Tue Jan 5 07:41:04 1999
-@@ -223,9 +223,9 @@
+@@ -231,9 +231,9 @@
var = getenv("GTK_EXE_PREFIX");
if (var)
@@ -12,7 +12,7 @@
return path;
}
-@@ -238,9 +238,9 @@
+@@ -246,9 +246,9 @@
var = getenv("GTK_DATA_PREFIX");
if (var)
@@ -24,7 +24,7 @@
for (n = 0; pixmap_path[n]; n++) ;
if (n >= GTK_RC_MAX_PIXMAP_PATHS - 1)
-@@ -274,15 +274,15 @@
+@@ -282,15 +282,15 @@
var = getenv("GTK_EXE_PREFIX");
if (var)
@@ -43,3 +43,12 @@
module_path[n++] = g_strdup(path);
module_path[n] = NULL;
g_free(path);
+@@ -324,7 +324,7 @@
+ }
+ else
+ {
+- str = g_strdup_printf ("%s%s", GTK_SYSCONFDIR, "/gtk/gtkrc");
++ str = g_strdup_printf ("%s%s", GTK_SYSCONFDIR, "/gtkrc");
+ gtk_rc_add_default_file (str);
+ g_free (str);
+
diff --git a/x11-toolkits/gtk20/files/patch-ae b/x11-toolkits/gtk20/files/patch-ae
index 20f506155853..854b0d4e5cc3 100644
--- a/x11-toolkits/gtk20/files/patch-ae
+++ b/x11-toolkits/gtk20/files/patch-ae
@@ -1,11 +1,11 @@
---- configure.orig Thu Feb 18 01:35:07 1999
-+++ configure Thu Feb 18 01:35:27 1999
-@@ -4444,7 +4444,7 @@
-
- # AM_GTK_GNU_GETTEXT above substs $DATADIRNAME
- # this is the directory where the *.{mo,gmo} files are installed
--gtklocaledir='${prefix}/${DATADIRNAME}/locale'
-+gtklocaledir='${prefix}/share/locale'
-
-
- echo $ac_n "checking for extra flags to get ANSI library prototypes""... $ac_c" 1>&6
+--- configure.orig Thu Feb 25 13:02:28 1999
++++ configure Tue Mar 2 11:11:14 1999
+@@ -3977,7 +3977,7 @@
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ CATOBJEXT=.mo
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ fi
+ rm -f conftest*
+ INSTOBJEXT=.mo
diff --git a/x11-toolkits/gtk20/pkg-descr b/x11-toolkits/gtk20/pkg-descr
index 15cddd29f66d..75f50206dbe7 100644
--- a/x11-toolkits/gtk20/pkg-descr
+++ b/x11-toolkits/gtk20/pkg-descr
@@ -2,10 +2,9 @@
the Motif "look and feel". It is designed to be small and efficient, but
still flexible enough to allow the programmer freedom in the interfaces
created. GTK allows the programmer to use a variety of standard user
-interface widgets (*note Widgets::.) such as push, radio and check
-buttons, menus, lists and frames. It also provides several "container"
-widgets which can be used to control the layout of the user interface
-elements.
+interface widgets such as push, radio and check buttons, menus, lists
+and frames. It also provides several "container" widgets which can be
+used to control the layout of the user interface elements.
GTK provides some unique features. (At least, I know of no other
widget library which provides them). For example, a button does not
diff --git a/x11-toolkits/gtk20/pkg-plist b/x11-toolkits/gtk20/pkg-plist
index 33398999e7a4..eaa533417e51 100644
--- a/x11-toolkits/gtk20/pkg-plist
+++ b/x11-toolkits/gtk20/pkg-plist
@@ -1,124 +1,124 @@
-bin/gtk11d-config
-include/gtk11d/gdk/gdk.h
-include/gtk11d/gdk/gdkcursors.h
-include/gtk11d/gdk/gdki18n.h
-include/gtk11d/gdk/gdkkeysyms.h
-include/gtk11d/gdk/gdkprivate.h
-include/gtk11d/gdk/gdkrgb.h
-include/gtk11d/gdk/gdktypes.h
-include/gtk11d/gdk/gdkx.h
-include/gtk11d/gtk/gtk.h
-include/gtk11d/gtk/gtkaccelgroup.h
-include/gtk11d/gtk/gtkaccellabel.h
-include/gtk11d/gtk/gtkadjustment.h
-include/gtk11d/gtk/gtkalignment.h
-include/gtk11d/gtk/gtkarg.h
-include/gtk11d/gtk/gtkarrow.h
-include/gtk11d/gtk/gtkaspectframe.h
-include/gtk11d/gtk/gtkbbox.h
-include/gtk11d/gtk/gtkbin.h
-include/gtk11d/gtk/gtkbindings.h
-include/gtk11d/gtk/gtkbox.h
-include/gtk11d/gtk/gtkbutton.h
-include/gtk11d/gtk/gtkcalendar.h
-include/gtk11d/gtk/gtkcheckbutton.h
-include/gtk11d/gtk/gtkcheckmenuitem.h
-include/gtk11d/gtk/gtkclist.h
-include/gtk11d/gtk/gtkcolorsel.h
-include/gtk11d/gtk/gtkcombo.h
-include/gtk11d/gtk/gtkcompat.h
-include/gtk11d/gtk/gtkcontainer.h
-include/gtk11d/gtk/gtkctree.h
-include/gtk11d/gtk/gtkcurve.h
-include/gtk11d/gtk/gtkdata.h
-include/gtk11d/gtk/gtkdebug.h
-include/gtk11d/gtk/gtkdialog.h
-include/gtk11d/gtk/gtkdnd.h
-include/gtk11d/gtk/gtkdrawingarea.h
-include/gtk11d/gtk/gtkeditable.h
-include/gtk11d/gtk/gtkentry.h
-include/gtk11d/gtk/gtkenums.h
-include/gtk11d/gtk/gtkeventbox.h
-include/gtk11d/gtk/gtkfeatures.h
-include/gtk11d/gtk/gtkfilesel.h
-include/gtk11d/gtk/gtkfixed.h
-include/gtk11d/gtk/gtkfontsel.h
-include/gtk11d/gtk/gtkframe.h
-include/gtk11d/gtk/gtkgamma.h
-include/gtk11d/gtk/gtkgc.h
-include/gtk11d/gtk/gtkhandlebox.h
-include/gtk11d/gtk/gtkhbbox.h
-include/gtk11d/gtk/gtkhbox.h
-include/gtk11d/gtk/gtkhpaned.h
-include/gtk11d/gtk/gtkhruler.h
-include/gtk11d/gtk/gtkhscale.h
-include/gtk11d/gtk/gtkhscrollbar.h
-include/gtk11d/gtk/gtkhseparator.h
-include/gtk11d/gtk/gtkimage.h
-include/gtk11d/gtk/gtkinputdialog.h
-include/gtk11d/gtk/gtkinvisible.h
-include/gtk11d/gtk/gtkitem.h
-include/gtk11d/gtk/gtkitemfactory.h
-include/gtk11d/gtk/gtklabel.h
-include/gtk11d/gtk/gtklayout.h
-include/gtk11d/gtk/gtklist.h
-include/gtk11d/gtk/gtklistitem.h
-include/gtk11d/gtk/gtkmain.h
-include/gtk11d/gtk/gtkmarshal.h
-include/gtk11d/gtk/gtkmenu.h
-include/gtk11d/gtk/gtkmenubar.h
-include/gtk11d/gtk/gtkmenufactory.h
-include/gtk11d/gtk/gtkmenuitem.h
-include/gtk11d/gtk/gtkmenushell.h
-include/gtk11d/gtk/gtkmisc.h
-include/gtk11d/gtk/gtknotebook.h
-include/gtk11d/gtk/gtkobject.h
-include/gtk11d/gtk/gtkoptionmenu.h
-include/gtk11d/gtk/gtkpacker.h
-include/gtk11d/gtk/gtkpaned.h
-include/gtk11d/gtk/gtkpixmap.h
-include/gtk11d/gtk/gtkplug.h
-include/gtk11d/gtk/gtkpreview.h
-include/gtk11d/gtk/gtkprivate.h
-include/gtk11d/gtk/gtkprogress.h
-include/gtk11d/gtk/gtkprogressbar.h
-include/gtk11d/gtk/gtkradiobutton.h
-include/gtk11d/gtk/gtkradiomenuitem.h
-include/gtk11d/gtk/gtkrange.h
-include/gtk11d/gtk/gtkrc.h
-include/gtk11d/gtk/gtkruler.h
-include/gtk11d/gtk/gtkscale.h
-include/gtk11d/gtk/gtkscrollbar.h
-include/gtk11d/gtk/gtkscrolledwindow.h
-include/gtk11d/gtk/gtkselection.h
-include/gtk11d/gtk/gtkseparator.h
-include/gtk11d/gtk/gtksignal.h
-include/gtk11d/gtk/gtksocket.h
-include/gtk11d/gtk/gtkspinbutton.h
-include/gtk11d/gtk/gtkstatusbar.h
-include/gtk11d/gtk/gtkstyle.h
-include/gtk11d/gtk/gtktable.h
-include/gtk11d/gtk/gtktearoffmenuitem.h
-include/gtk11d/gtk/gtktext.h
-include/gtk11d/gtk/gtkthemes.h
-include/gtk11d/gtk/gtktipsquery.h
-include/gtk11d/gtk/gtktogglebutton.h
-include/gtk11d/gtk/gtktoolbar.h
-include/gtk11d/gtk/gtktooltips.h
-include/gtk11d/gtk/gtktree.h
-include/gtk11d/gtk/gtktreeitem.h
-include/gtk11d/gtk/gtktypebuiltins.h
-include/gtk11d/gtk/gtktypeutils.h
-include/gtk11d/gtk/gtkvbbox.h
-include/gtk11d/gtk/gtkvbox.h
-include/gtk11d/gtk/gtkviewport.h
-include/gtk11d/gtk/gtkvpaned.h
-include/gtk11d/gtk/gtkvruler.h
-include/gtk11d/gtk/gtkvscale.h
-include/gtk11d/gtk/gtkvscrollbar.h
-include/gtk11d/gtk/gtkvseparator.h
-include/gtk11d/gtk/gtkwidget.h
-include/gtk11d/gtk/gtkwindow.h
+bin/gtk12-config
+include/gtk12/gdk/gdk.h
+include/gtk12/gdk/gdkcursors.h
+include/gtk12/gdk/gdki18n.h
+include/gtk12/gdk/gdkkeysyms.h
+include/gtk12/gdk/gdkprivate.h
+include/gtk12/gdk/gdkrgb.h
+include/gtk12/gdk/gdktypes.h
+include/gtk12/gdk/gdkx.h
+include/gtk12/gtk/gtk.h
+include/gtk12/gtk/gtkaccelgroup.h
+include/gtk12/gtk/gtkaccellabel.h
+include/gtk12/gtk/gtkadjustment.h
+include/gtk12/gtk/gtkalignment.h
+include/gtk12/gtk/gtkarg.h
+include/gtk12/gtk/gtkarrow.h
+include/gtk12/gtk/gtkaspectframe.h
+include/gtk12/gtk/gtkbbox.h
+include/gtk12/gtk/gtkbin.h
+include/gtk12/gtk/gtkbindings.h
+include/gtk12/gtk/gtkbox.h
+include/gtk12/gtk/gtkbutton.h
+include/gtk12/gtk/gtkcalendar.h
+include/gtk12/gtk/gtkcheckbutton.h
+include/gtk12/gtk/gtkcheckmenuitem.h
+include/gtk12/gtk/gtkclist.h
+include/gtk12/gtk/gtkcolorsel.h
+include/gtk12/gtk/gtkcombo.h
+include/gtk12/gtk/gtkcompat.h
+include/gtk12/gtk/gtkcontainer.h
+include/gtk12/gtk/gtkctree.h
+include/gtk12/gtk/gtkcurve.h
+include/gtk12/gtk/gtkdata.h
+include/gtk12/gtk/gtkdebug.h
+include/gtk12/gtk/gtkdialog.h
+include/gtk12/gtk/gtkdnd.h
+include/gtk12/gtk/gtkdrawingarea.h
+include/gtk12/gtk/gtkeditable.h
+include/gtk12/gtk/gtkentry.h
+include/gtk12/gtk/gtkenums.h
+include/gtk12/gtk/gtkeventbox.h
+include/gtk12/gtk/gtkfeatures.h
+include/gtk12/gtk/gtkfilesel.h
+include/gtk12/gtk/gtkfixed.h
+include/gtk12/gtk/gtkfontsel.h
+include/gtk12/gtk/gtkframe.h
+include/gtk12/gtk/gtkgamma.h
+include/gtk12/gtk/gtkgc.h
+include/gtk12/gtk/gtkhandlebox.h
+include/gtk12/gtk/gtkhbbox.h
+include/gtk12/gtk/gtkhbox.h
+include/gtk12/gtk/gtkhpaned.h
+include/gtk12/gtk/gtkhruler.h
+include/gtk12/gtk/gtkhscale.h
+include/gtk12/gtk/gtkhscrollbar.h
+include/gtk12/gtk/gtkhseparator.h
+include/gtk12/gtk/gtkimage.h
+include/gtk12/gtk/gtkinputdialog.h
+include/gtk12/gtk/gtkinvisible.h
+include/gtk12/gtk/gtkitem.h
+include/gtk12/gtk/gtkitemfactory.h
+include/gtk12/gtk/gtklabel.h
+include/gtk12/gtk/gtklayout.h
+include/gtk12/gtk/gtklist.h
+include/gtk12/gtk/gtklistitem.h
+include/gtk12/gtk/gtkmain.h
+include/gtk12/gtk/gtkmarshal.h
+include/gtk12/gtk/gtkmenu.h
+include/gtk12/gtk/gtkmenubar.h
+include/gtk12/gtk/gtkmenufactory.h
+include/gtk12/gtk/gtkmenuitem.h
+include/gtk12/gtk/gtkmenushell.h
+include/gtk12/gtk/gtkmisc.h
+include/gtk12/gtk/gtknotebook.h
+include/gtk12/gtk/gtkobject.h
+include/gtk12/gtk/gtkoptionmenu.h
+include/gtk12/gtk/gtkpacker.h
+include/gtk12/gtk/gtkpaned.h
+include/gtk12/gtk/gtkpixmap.h
+include/gtk12/gtk/gtkplug.h
+include/gtk12/gtk/gtkpreview.h
+include/gtk12/gtk/gtkprivate.h
+include/gtk12/gtk/gtkprogress.h
+include/gtk12/gtk/gtkprogressbar.h
+include/gtk12/gtk/gtkradiobutton.h
+include/gtk12/gtk/gtkradiomenuitem.h
+include/gtk12/gtk/gtkrange.h
+include/gtk12/gtk/gtkrc.h
+include/gtk12/gtk/gtkruler.h
+include/gtk12/gtk/gtkscale.h
+include/gtk12/gtk/gtkscrollbar.h
+include/gtk12/gtk/gtkscrolledwindow.h
+include/gtk12/gtk/gtkselection.h
+include/gtk12/gtk/gtkseparator.h
+include/gtk12/gtk/gtksignal.h
+include/gtk12/gtk/gtksocket.h
+include/gtk12/gtk/gtkspinbutton.h
+include/gtk12/gtk/gtkstatusbar.h
+include/gtk12/gtk/gtkstyle.h
+include/gtk12/gtk/gtktable.h
+include/gtk12/gtk/gtktearoffmenuitem.h
+include/gtk12/gtk/gtktext.h
+include/gtk12/gtk/gtkthemes.h
+include/gtk12/gtk/gtktipsquery.h
+include/gtk12/gtk/gtktogglebutton.h
+include/gtk12/gtk/gtktoolbar.h
+include/gtk12/gtk/gtktooltips.h
+include/gtk12/gtk/gtktree.h
+include/gtk12/gtk/gtktreeitem.h
+include/gtk12/gtk/gtktypebuiltins.h
+include/gtk12/gtk/gtktypeutils.h
+include/gtk12/gtk/gtkvbbox.h
+include/gtk12/gtk/gtkvbox.h
+include/gtk12/gtk/gtkviewport.h
+include/gtk12/gtk/gtkvpaned.h
+include/gtk12/gtk/gtkvruler.h
+include/gtk12/gtk/gtkvscale.h
+include/gtk12/gtk/gtkvscrollbar.h
+include/gtk12/gtk/gtkvseparator.h
+include/gtk12/gtk/gtkwidget.h
+include/gtk12/gtk/gtkwindow.h
@unexec install-info --delete %D/info/gdk.info %D/info/dir
@unexec install-info --delete %D/info/gtk.info %D/info/dir
info/gdk.info
@@ -126,20 +126,21 @@ info/gtk.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/gdk.info %D/info/dir
@exec install-info %D/info/gtk.info %D/info/dir
-lib/libgdk11d.a
-lib/libgdk11d.la
-lib/libgdk11d.so
-lib/libgdk11d.so.1.3
-lib/libgtk11d.a
-lib/libgtk11d.la
-lib/libgtk11d.so
-lib/libgtk11d.so.1.3
+lib/libgdk12.a
+lib/libgdk12.la
+lib/libgdk12.so
+lib/libgdk12.so.1
+lib/libgtk12.a
+lib/libgtk12.la
+lib/libgtk12.so
+lib/libgtk12.so.1
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/locale/cs/LC_MESSAGES/gtk+.mo
share/locale/de/LC_MESSAGES/gtk+.mo
share/locale/es/LC_MESSAGES/gtk+.mo
share/locale/fr/LC_MESSAGES/gtk+.mo
+share/locale/hu/LC_MESSAGES/gtk+.mo
share/locale/it/LC_MESSAGES/gtk+.mo
share/locale/ja/LC_MESSAGES/gtk+.mo
share/locale/ko/LC_MESSAGES/gtk+.mo
@@ -150,10 +151,14 @@ share/locale/pt/LC_MESSAGES/gtk+.mo
share/locale/ru/LC_MESSAGES/gtk+.mo
share/locale/sv/LC_MESSAGES/gtk+.mo
share/themes/Default/gtk/gtkrc
+share/themes/Default/gtk/gtkrc.ja
+share/themes/Default/gtk/gtkrc.ko
+share/themes/Default/gtk/gtkrc.ru
+@exec mkdir -p %D/share/themes/engines
@dirrm share/themes/Default/gtk
@dirrm share/themes/Default
@dirrm share/themes/engines
@dirrm share/themes
-@dirrm include/gtk11d/gdk
-@dirrm include/gtk11d/gtk
-@dirrm include/gtk11d
+@dirrm include/gtk12/gdk
+@dirrm include/gtk12/gtk
+@dirrm include/gtk12