aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtkmm20-reference/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtkmm20-reference/Makefile')
-rw-r--r--x11-toolkits/gtkmm20-reference/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-toolkits/gtkmm20-reference/Makefile b/x11-toolkits/gtkmm20-reference/Makefile
new file mode 100644
index 000000000000..cad3452fd57c
--- /dev/null
+++ b/x11-toolkits/gtkmm20-reference/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PATCH_DEPENDS= ${NONEXISTENT}:${.CURDIR}/../gtk--2:patch
+BUILD_DEPENDS= ${NONEXISTENT}:${.CURDIR}/../gtk--2:configure
+
+PARENT_WRKSRC!= cd ${.CURDIR}/../gtk--2 && ${MAKE} -V WRKSRC
+EXTRACT_ONLY=
+USE_GMAKE= yes
+
+DOCSDIR= ${PREFIX}/share/doc/gtkmm-2.0
+
+post-patch:
+ @${FIND} ${PARENT_WRKSRC}/examples -name Makefile.in \
+ | ${XARGS} ${REINPLACE_CMD} -e '/^install-am:/ s| all-am||'
+
+do-install:
+.for d in docs examples
+ @cd ${PARENT_WRKSRC}/${d} && ${GMAKE} install
+.endfor
+
+.include "${.CURDIR}/../../devel/glib20-reference/bsd.gnome-reference.mk"