aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/lesstif/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/lesstif/Makefile')
-rw-r--r--x11-toolkits/lesstif/Makefile50
1 files changed, 2 insertions, 48 deletions
diff --git a/x11-toolkits/lesstif/Makefile b/x11-toolkits/lesstif/Makefile
index c706e9887843..5bc90179a0dd 100644
--- a/x11-toolkits/lesstif/Makefile
+++ b/x11-toolkits/lesstif/Makefile
@@ -15,7 +15,6 @@ LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
freetype:${PORTSDIR}/print/freetype2
CONFLICTS?= open-motif-*
-NO_STAGE= yes
USE_BZIP2= yes
USE_AUTOTOOLS= automake:env autoconf libtool
@@ -26,50 +25,6 @@ CONFIGURE_ARGS+= --enable-static --enable-shared --enable-production
CONFIGURE_ARGS+= --disable-maintainer-mode
CFLAGS+= -I${LOCALBASE}/include
-MAN1 = lesstif.1 ltversion.1 mwm.1 uil.1 xmbind.1
-
-MAN3 = ApplicationShell.3 Composite.3 Constraint.3 Core.3 \
- LessTifInternals.3 Object.3 OverrideShell.3 Rect.3 Shell.3 \
- TopLevelShell.3 TransientShell.3 UnNamedObj.3 VendorShell.3 \
- WmShell.3 XmArrowButton.3 XmArrowButtonGadget.3 XmBulletinBoard.3 \
- XmCascadeButton.3 XmCascadeButtonGadget.3 XmClipboard.3 \
- XmComboBox.3 XmCommand.3 XmDesktop.3 XmDialogShell.3 \
- XmDialogShellExt.3 XmDisplay.3 XmDragContext.3 XmDragIcon.3 \
- XmDragOverShell.3 XmDrawingArea.3 XmDrawnButton.3 XmDropSiteManager.3 \
- XmDropTransfer.3 XmFileSelectionBox.3 XmForm.3 XmFrame.3 XmGadget.3 \
- XmGrabShell.3 XmIconGadget.3 XmLabel.3 XmLabelGadget.3 XmList.3 \
- XmMainWindow.3 XmManager.3 XmMenuShell.3 XmMessageBox.3 XmNotebook.3 \
- XmPanedWindow.3 XmPrimitive.3 XmProtocol.3 XmPushButton.3 \
- XmPushButtonGadget.3 XmRowColumn.3 XmSash.3 XmScale.3 XmScreen.3 \
- XmScrollBar.3 XmScrolledWindow.3 XmSelectionBox.3 XmSeparator.3 \
- XmSeparatorGadget.3 XmSpinBox.3 XmString.3 XmTearOffButton.3 XmText.3 \
- XmTextField.3 XmToggleButton.3 XmToggleButtonGadget.3 XmVendorShell.3 \
- XmWorld.3
-
-MAN5 = VirtualBindings.5 mwmrc.5
-
-.if defined(HAVE_MOTIF) && !defined(PACKAGE_BUILDING) && !defined(BATCH) && !defined(WANT_LESSTIF)
-MANUAL_PACKAGE_BUILD= do not want to install during interactive build
-IS_INTERACTIVE= yes
-pre-extract:
- @${ECHO_CMD} "***********************************************************"
- @${ECHO_CMD} "* W a r n i n g *"
- @${ECHO_CMD} "* This port will overwrite your Motif installation. *"
- @${ECHO_CMD} "***********************************************************"
- @${ECHO_CMD} -n "Is this ok? (y/n) ==> "
- @(read ans; \
- case x"$$ans" in \
- xy*|xY*) \
- return 0; \
- ;; \
- *) \
- ${ECHO_CMD} "Okay, I won't install it then...."; \
- ${ECHO_CMD} "(Don't worry about the following \"*** Error code 1's)"; \
- return 1; \
- ;; \
- esac)
-.endif
-
post-patch:
${REINPLACE_CMD} \
-e 's|LT_HAVE_FREETYPE|FINDXFT_HAVE_FREETYPE|g' \
@@ -77,8 +32,7 @@ post-patch:
${WRKSRC}/acinclude.m4
post-install:
- @${INSTALL_DATA} ${WRKSRC}/scripts/autoconf/ac_find_motif.m4 \
- ${PREFIX}/share/aclocal
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${WRKSRC}/scripts/autoconf/ac_find_motif.m4 \
+ ${STAGEDIR}${PREFIX}/share/aclocal
.include <bsd.port.mk>