aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/linux-f8-openmotif/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/linux-f8-openmotif/Makefile')
-rw-r--r--x11-toolkits/linux-f8-openmotif/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/x11-toolkits/linux-f8-openmotif/Makefile b/x11-toolkits/linux-f8-openmotif/Makefile
index d1ca9a372f32..2f81546cd56c 100644
--- a/x11-toolkits/linux-f8-openmotif/Makefile
+++ b/x11-toolkits/linux-f8-openmotif/Makefile
@@ -5,15 +5,14 @@
# $FreeBSD$
PORTNAME= openmotif
-PORTVERSION= 2.2.4
+PORTVERSION= 2.3.2
CATEGORIES= x11-toolkits linux
MASTER_SITES= ftp://ftp.motifzone.com/%SUBDIR%/ \
- ftp://ftp.ics.com/pub/Products/Motif/%SUBDIR%/
-MASTER_SITE_SUBDIR= om2.2.4/redhat-7.3
+ ftp://ftp.ics.com/openmotif/%SUBDIR%/
+MASTER_SITE_SUBDIR= 2.3/${PORTVERSION}
PKGNAMEPREFIX= linux-f8-
-EXTRACT_SUFX= -0.1.i386.rpm
+EXTRACT_SUFX= -1.fc8.i386.rpm
DIST_SUBDIR= rpm
-EXTRACT_ONLY=
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Motif toolkit Linux libraries
@@ -21,20 +20,14 @@ COMMENT= Motif toolkit Linux libraries
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
+USE_LINUX_RPM= yes
USE_LINUX_APPS= xorglibs
-USE_LINUX_PREFIX= yes
-NO_BUILD= yes
+USE_LDCONFIG= yes
+SRC_DISTFILES=
MD5_FILE= ${MASTERDIR}/distinfo.i386
-EXTRACT_FILES= ./usr/X11R6/lib/libMrm.so.3.0.3 \
- ./usr/X11R6/lib/libUil.so.3.0.3 \
- ./usr/X11R6/lib/libXm.so.3.0.3
-
-do-install:
- cd ${PREFIX}; \
- rpm2cpio ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} | \
- ${CPIO} -idum -R ${LIBOWN}:${LIBGRP} ${EXTRACT_FILES}
- chroot ${PREFIX} /sbin/ldconfig
+post-extract:
+ @${RM} -r ${WRKSRC}/etc ${WRKSRC}/usr/bin ${WRKSRC}/usr/include \
+ ${WRKSRC}/usr/share ${WRKSRC}/usr/lib/X11
.include <bsd.port.mk>