aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pango
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/pango')
-rw-r--r--x11-toolkits/pango/Makefile2
-rw-r--r--x11-toolkits/pango/files/patch-modules_indic_indic-ot.h12
-rw-r--r--x11-toolkits/pango/files/patch-pango_opentype_ftxopen.h12
-rw-r--r--x11-toolkits/pango/files/patch-pango_opentype_pango-ot-info.c11
-rw-r--r--x11-toolkits/pango/files/patch-pango_opentype_pango-ot-private.h12
-rw-r--r--x11-toolkits/pango/files/patch-pango_pango-ot.h12
-rw-r--r--x11-toolkits/pango/files/patch-pango_pangoft2.c12
-rw-r--r--x11-toolkits/pango/files/patch-pango_pangoft2.h12
8 files changed, 84 insertions, 1 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 825f2e253c2e..e670b79e193f 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pango
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/1.2,} \
ftp://ftp.gtk.org/pub/gtk/v2.2/
diff --git a/x11-toolkits/pango/files/patch-modules_indic_indic-ot.h b/x11-toolkits/pango/files/patch-modules_indic_indic-ot.h
new file mode 100644
index 000000000000..9e6a2e4292d0
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-modules_indic_indic-ot.h
@@ -0,0 +1,12 @@
+--- modules/indic/indic-ot.h.orig Tue Mar 16 16:23:13 2004
++++ modules/indic/indic-ot.h Tue Mar 16 16:23:38 2004
+@@ -9,7 +9,8 @@
+ #ifndef __INDIC_OT_H__
+ #define __INDIC_OT_H__
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <pango/pango-glyph.h>
+ #include <pango/pango-types.h>
+ #include "mprefixups.h"
diff --git a/x11-toolkits/pango/files/patch-pango_opentype_ftxopen.h b/x11-toolkits/pango/files/patch-pango_opentype_ftxopen.h
new file mode 100644
index 000000000000..25a937a88ef1
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_opentype_ftxopen.h
@@ -0,0 +1,12 @@
+--- pango/opentype/ftxopen.h.orig Tue Mar 16 16:19:27 2004
++++ pango/opentype/ftxopen.h Tue Mar 16 16:19:45 2004
+@@ -22,7 +22,8 @@
+ #ifndef FTXOPEN_H
+ #define FTXOPEN_H
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #ifdef __cplusplus
+ extern "C" {
diff --git a/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-info.c b/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-info.c
new file mode 100644
index 000000000000..0deb4b92e48c
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-info.c
@@ -0,0 +1,11 @@
+--- pango/opentype/pango-ot-info.c.orig Tue Mar 16 16:18:19 2004
++++ pango/opentype/pango-ot-info.c Tue Mar 16 16:17:38 2004
+@@ -22,7 +22,7 @@
+ #include "pango-ot-private.h"
+ #include "fterrcompat.h"
+ #include <freetype/internal/ftobjs.h>
+-#include <freetype/ftmodule.h>
++#include <freetype/ftmodapi.h>
+
+ static void pango_ot_info_class_init (GObjectClass *object_class);
+ static void pango_ot_info_finalize (GObject *object);
diff --git a/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-private.h b/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-private.h
new file mode 100644
index 000000000000..0d2e0c944177
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_opentype_pango-ot-private.h
@@ -0,0 +1,12 @@
+--- pango/opentype/pango-ot-private.h.orig Tue Mar 16 16:16:35 2004
++++ pango/opentype/pango-ot-private.h Tue Mar 16 16:18:53 2004
+@@ -22,7 +22,8 @@
+ #ifndef __PANGO_OT_PRIVATE_H__
+ #define __PANGO_OT_PRIVATE_H__
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #include <glib-object.h>
+
diff --git a/x11-toolkits/pango/files/patch-pango_pango-ot.h b/x11-toolkits/pango/files/patch-pango_pango-ot.h
new file mode 100644
index 000000000000..61e68f7207e7
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_pango-ot.h
@@ -0,0 +1,12 @@
+--- pango/pango-ot.h.orig Tue Mar 16 16:21:00 2004
++++ pango/pango-ot.h Tue Mar 16 16:21:18 2004
+@@ -22,7 +22,8 @@
+ #ifndef __PANGO_OT_H__
+ #define __PANGO_OT_H__
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <pango/pango-glyph.h>
+
+ G_BEGIN_DECLS
diff --git a/x11-toolkits/pango/files/patch-pango_pangoft2.c b/x11-toolkits/pango/files/patch-pango_pangoft2.c
new file mode 100644
index 000000000000..f1d05cd84dfd
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_pangoft2.c
@@ -0,0 +1,12 @@
+--- pango/pangoft2.c.orig Tue Mar 16 16:21:59 2004
++++ pango/pangoft2.c Tue Mar 16 16:22:20 2004
+@@ -28,7 +28,8 @@
+ #include <glib.h>
+ #include <glib/gprintf.h>
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #include "pango-utils.h"
+ #include "pangoft2.h"
diff --git a/x11-toolkits/pango/files/patch-pango_pangoft2.h b/x11-toolkits/pango/files/patch-pango_pangoft2.h
new file mode 100644
index 000000000000..af7dcded906f
--- /dev/null
+++ b/x11-toolkits/pango/files/patch-pango_pangoft2.h
@@ -0,0 +1,12 @@
+--- pango/pangoft2.h.orig Tue Mar 16 16:14:49 2004
++++ pango/pangoft2.h Tue Mar 16 16:15:21 2004
+@@ -23,7 +23,8 @@
+ #ifndef __PANGOFT2_H__
+ #define __PANGOFT2_H__
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #include <fontconfig/fontconfig.h>
+