aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-qt4-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt4-gui/Makefile')
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index cc04047612e6..a0487b9ee454 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= x11-toolkits devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtGui module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core
-
CONFIGURE_ARGS= --enable QtGui
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build core_run
USE_QT4= gui imageformats_run inputmethods_run iconengines_run \
qmake_build moc_build
@@ -28,5 +28,4 @@ DEBUG_CONFIGURE_ON= --debug --trace
BROKEN_sparc64= Does not compile on sparc64
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>