aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-qt4-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/py-qt4-gui/Makefile')
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile33
1 files changed, 11 insertions, 22 deletions
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index cee7bcac2bf7..5fe97ce7c33f 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -25,29 +25,28 @@ USE_PYTHON= 2.5+
USE_QT4= gui imageformats_run inputmethods_run iconengines_run \
qmake_build moc_build
-OPTIONS= API "Install QtGui API for QScintilla2" on \
- DEBUG "Enable debugging in generated code" off \
- SIPFILES "Install the QtGui SIP files" on \
- TRACING "Enable tracing in generated code" off
+OPTIONS= API "Install QtGui API for QScintilla2" on
PATCHDIR= ${PORTSDIR}/devel/py-qt4-core/files
OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
QSCIDIR= ${PREFIX}/share/qt4/qsci
CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
-ARGS= -b ${PREFIX}/bin\
- -d ${PYTHONPREFIX_SITELIBDIR}\
- -p ${PREFIX}/${QT_PLUGINDIR_REL}\
- -q ${QMAKE}\
- --confirm-license\
+ARGS= -b ${PREFIX}/bin \
+ -d ${PYTHONPREFIX_SITELIBDIR} \
+ -p ${PREFIX}/${QT_PLUGINDIR_REL} \
+ -q ${QMAKE} \
+ --confirm-license \
+ --sipdir ${SIPDIR} \
--enable QtGui
+.if defined(WITH_DEBUG)
+ARGS+= --debug --trace
+.endif
+
.include "../../devel/py-sip/files/bsd.pyqt.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-ARGS+= --debug
-.endif
.if defined(WITHOUT_API)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
@@ -56,16 +55,6 @@ LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
-.if defined(WITHOUT_SIPFILES)
-ARGS+= --no-sip-files
-PLIST_SUB+= SIP="@comment "
-.else
-ARGS+= --sipdir ${SIPDIR}
-PLIST_SUB+= SIP=""
-.endif
-.if defined(WITH_TRACING)
-ARGS+= --trace
-.endif
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64