aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qwt6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qwt6/Makefile')
-rw-r--r--x11-toolkits/qwt6/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index d7d4e0e6f284..8fbd10240f84 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -9,11 +9,9 @@ PKGNAMESUFFIX= 6
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Widgets for Technical Applications
+USES= gmake qmake
USE_QT4= gui opengl svg xml moc_build qmake_build
USE_BZIP2= yes
-USE_GMAKE= yes
-QMAKE_ARGS+= -recursive PREFIX=${PREFIX}
-HAS_CONFIGURE= yes
USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/qwt6
@@ -28,7 +26,6 @@ STRIP_FILES= lib/libqwt6.so.${PORTVERSION} \
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -37,13 +34,10 @@ post-patch:
qwt.prf textengines/textengines.pri && \
${REINPLACE_CMD} -e '/INSTALLS.*doc/d' doc/doc.pro
-do-configure:
- (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
-
post-install:
- ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
.if ${PORT_OPTIONS:MDOCS}
- (cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
+ (cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.endif
.include <bsd.port.mk>