aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/ruby-gtksourceview2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ruby-gtksourceview2/Makefile')
-rw-r--r--x11-toolkits/ruby-gtksourceview2/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-toolkits/ruby-gtksourceview2/Makefile b/x11-toolkits/ruby-gtksourceview2/Makefile
new file mode 100644
index 000000000000..c9d5c2a03296
--- /dev/null
+++ b/x11-toolkits/ruby-gtksourceview2/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ruby-gtksourceview2
+# Date created: 2010-11-19
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtksourceview2
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= x11-toolkits gnome ruby
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby binding for GtkSourceView2
+
+BUILD_DEPENDS+= rubygem-pkg-config>=1.0.7:${PORTSDIR}/devel/rubygem-pkg-config
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
+
+USE_RUBY= yes
+USE_GNOME= gtksourceview2
+USE_RUBY_EXTCONF= yes
+CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
+
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/gtksourceview2
+INSTALL_TARGET= site-install
+
+DOCS= COPYING.LIB ChangeLog README
+
+post-patch: general-patch
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>