aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/swt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/swt/Makefile')
-rw-r--r--x11-toolkits/swt/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index ec34166faa23..a3665b7f602a 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -83,6 +83,10 @@ post-extract:
@(cd ${WRKSRC} && ${UNZIP_CMD} -qo "*.zip")
@${RM} -f ${WRKSRC}/*.o ${WRKSRC}/*.so ${WRKSRC}/*.jar
+post-patch:
+ ${SED} -e 's|freebsd|dragonfly|g' ${WRKSRC}/make_freebsd.mak \
+ ${WRKSRC}/make_dragonfly.mak
+
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
${INSTALL_LIB} ${WRKSRC}/libswt-*.so ${STAGEDIR}${PREFIX}/lib