aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/viewklass/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/viewklass/Makefile')
-rw-r--r--x11-toolkits/viewklass/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-toolkits/viewklass/Makefile b/x11-toolkits/viewklass/Makefile
new file mode 100644
index 000000000000..961d26fed377
--- /dev/null
+++ b/x11-toolkits/viewklass/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: viewklass
+# Date created: Jun 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewklass
+PORTVERSION= 0.5.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ViewKlass-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_MOTIF= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${PERL} -pi -e "s/^CFLAGS=/CFLAGS+=/g ; s/^CXXFLAGS=/CXXFLAGS+=/g ; \
+ s/-g -Wall//g" ${WRKSRC}/Makefile.in
+
+post-install:
+.for file in libvk.a libvkhelp.a
+ @${STRIP_CMD} ${PREFIX}/lib/${file}
+.endfor
+
+.include <bsd.port.mk>