aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-kde/Makefile2
-rw-r--r--x11-toolkits/py-kde/files/patch-extensions__dcopexport.py28
2 files changed, 29 insertions, 1 deletions
diff --git a/x11-toolkits/py-kde/Makefile b/x11-toolkits/py-kde/Makefile
index 50fafdd36693..ce03c6af1f0d 100644
--- a/x11-toolkits/py-kde/Makefile
+++ b/x11-toolkits/py-kde/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kde
PORTVERSION= 4.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits python kde
MASTER_SITES= http://www.river-bank.demon.co.uk/download/PyKDE2/ \
http://freebsd.ricin.com/ports/distfiles/
diff --git a/x11-toolkits/py-kde/files/patch-extensions__dcopexport.py b/x11-toolkits/py-kde/files/patch-extensions__dcopexport.py
new file mode 100644
index 000000000000..c8172af935d5
--- /dev/null
+++ b/x11-toolkits/py-kde/files/patch-extensions__dcopexport.py
@@ -0,0 +1,28 @@
+--- extensions/dcopexport.py.orig Thu Dec 1 22:05:41 2005
++++ extensions/dcopexport.py Thu Dec 1 22:06:24 2005
+@@ -85,15 +85,16 @@
+ result = self.method.pymethod (*arglist)
+
+ # marshall the result as 'replyData'
+- s = QDataStream (replyData, IO_WriteOnly)
+- if self.method.rtype in numericTypes:
+- dcop_add (s, result, self.method.rtype)
+- elif self.method.rtype in stringTypes and isinstance (result, str):
+- dcop_add (s, eval ("%s('''%s''')" % (self.method.rtype, result)))
+- elif self.method.rtype.startswith ("QMap") or self.method.rtype.startswith ("QValueList"):
+- dcop_add (params, args [i], self.argtypes [i])
+- else:
+- dcop_add (s, result)
++ if self.method.rtype != "void":
++ s = QDataStream (replyData, IO_WriteOnly)
++ if self.method.rtype in numericTypes:
++ dcop_add (s, result, self.method.rtype)
++ elif self.method.rtype in stringTypes and isinstance (result, str):
++ dcop_add (s, eval ("%s('''%s''')" % (self.method.rtype, result)))
++ elif self.method.rtype.startswith ("QMap") or self.method.rtype.startswith ("QValueList"):
++ dcop_add (params, args [i], self.argtypes [i])
++ else:
++ dcop_add (s, result)
+
+ # use append because we want to return the replyType reference,
+ # not a new QCString