aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile3
-rw-r--r--x11-toolkits/gtk30/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index a02f9ce8f997..3001ebcaaaad 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -78,7 +78,8 @@ STRIP=
# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
# for detail.
-.if ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) && ${CC} != "icc"
+.if ${OSVERSION} >= 500000 && ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) \
+ && ${CC} != "icc"
CFLAGS+= -mno-sse2
.endif
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index a02f9ce8f997..3001ebcaaaad 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -78,7 +78,8 @@ STRIP=
# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
# for detail.
-.if ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) && ${CC} != "icc"
+.if ${OSVERSION} >= 500000 && ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) \
+ && ${CC} != "icc"
CFLAGS+= -mno-sse2
.endif